Jump to content

Can you use other than English on OSx86?


3 posts in this topic

Recommended Posts

Hi, I'm a Japanese OSx86 user.


Owing to blex0r and many other users' minute description,

I'd finally boot up OSx86 on my ThinkPad X41 successfully.



But, a problem was occurred.

I finished to set up OSx86 in English environment when 1st boot,

and changed to Japanese environment in "International" on "System Preferences",

then, mouse pointer was changed to rainbow beech ball and GUI was hanged!


Similarly, inputting or viewing Japanese in Cocoa applications

(like "TextEdit.app") by "Kotoeri" (Japanese Input Method)

causes GUI hang up too.

# Carbon applications (like "Finder.app") seems to be safe from Japanese.


Is anyone who can using language other than English on OSx86 exists?

(And any method to use Japanese?)


Sorry for my bad English.

Best regards.




Method which I used is below.

1. Installed Darwin 8.1.

2. Overwrote OSx86 with "ditto".

3. Imported "IOATAFamily.kext" and "ApplePS2Controller.kext" from Darwin 8.1.

4. Patched "CoreGraphics" and "oah750d".

Link to comment
Share on other sites

I solved this problem temporarily.


In without-SSE3 PC, OpenType fonts will cause it.

To fix, you may execute below in "Terminal.app".


sudo mkdir /System/Library/Fonts_disabled/
sudo mv /System/Library/Fonts/*.otf /System/Library/Fonts_disabled/


To grasp more detail, see below.





I expect for the replacement of Rosetta, to emulate ATSServer completely.

Link to comment
Share on other sites

This problem was solved completely by kernel patch made by Maxxuss.

(File name of it is 'Maxxuss-mach_kernel_v0.1'.)

After applying of the patch, all fonts can be used comfortably in my PC!!

(if your CPU is SSE3-capable, this patch will not required.)

Link to comment
Share on other sites


  • Create New...