Jump to content

Success - Gigabyte EX58-UDP5 i7 Snow Leopard


1 post in this topic

Recommended Posts

Hi All -


I am a complete newbie with osx on non-mac hardware, and just went through the install process over the last few days. It was not smooth, and in the course of working through this I feel like I learned a few things that I thought I'd share.


I have a couple of general thoughts on the process:


1. Even though there are guides out there that make it look like a straightforward "step-by-step for success" process, and even with the same hardware in those guides, it seems like it is possible to have an unsuccessful outcome. I take this from the fact that a) I had problems using the exact same board that apparently the author of the guide I used (digital_dreamer's excellent 10.6 for EX58-UDP guide) didn't experience, and :( you can tell from the follow-up posts to the various guides that many many people seem to have various issues that others aren't seeing even on the same hardware.


2. There is a ton of information out there, but it's really really hard to access and understand. I'm relatively savvy with computers, but without a great deal of research and time it will be difficult to fully understand what all the various terminology means. Most guides/posts use terms / language that isn't understandable to people without experience with this stuff, and rarely offer a full and clear top-to-bottom explanation of those terms or concepts. The sites that are often linked or referred to, like netkas etc, offer virtually no explanation of what their tools/kexts/etc do. So, I wouldn't recommend this to someone who isn't pretty computer savvy, and would warn anyone that you may face problems, and then your will experience information overload, confusion, and possible head-explosion (your head).


My config:


EX58-UDP5 mobo

6GB ram (I guess OCZ 1066)

i7 920 2.66ghz

Initially tried XFX 9800GT 512MB, and COULDN'T GET IT TO WORK NO MATTER WHAT, so I went back to an MSI 9400GT

Initially tried to get the on-board ethernet working and COULDN'T GET IT TO WORK, so I installed a d-link DFE-530T gigabit PCI card.

1GB segate sata drive


What worked for me, and what didn't work:


a. I mainly used the excellent script from digital_dreamer for installing retail 10.6, and referred to the "x58 snow leopard retail install" post by digital_dreamer for instruction.

b. I used a second mac (my macbook pro) for the initial install process, and had my hard drive in an external USB cradle connected to the macbook pro. The MBP is running snow leopard.

c. The script is great, and greatly simplifies the install process, however even it is a little complicated because it offers a lot of options.

d. I installed and wiped the hard drive about 10 times before I finally figured out "basically" what was going on and got a working solution.

e. No problems whatsoever doing the basic install, which is to say formatting the drive, installing the bootloader from the script, installing from the retail dvd image, and installing kexts.

f. I tried every combination of install / bootloader, and the one that seemed to work best was system partition (not EFI partition), and PC-EFI v10.2.

g. Booting was no problem always, meaning I could always succesfully get to the mac desktop. However with PC-EFI v10.2 I got sound, and with Chameleon I could never get sound. Don't know why. I followed the same kext install procedure, with the audio kexts in /System, but Chameleon just refused to get sound going.

h. I got slightly different results with Chameleon / PC-EFI re ethernet as well, but nothing resulted in a good working solution. With one (can't remember which) ethernet just didn't show up. With the other, ethernet showed up buy would never get an IP addrs from DHCP. In the end I went with my trusty d-link card, and found the skge.kext (ver e-u) worked. I found it on a message board somewhere. From that point ethernet is working great, totally reliable, 1gpbs, and I have disabled the on-board lan ports.

i. I struggled most with video. The XFX 9800GT card just REFUSED to work. I looked at 1000 posts, some of which refer to this card specifically, and I followed the exact directions, but literally every time I tried something my screen would just go black after (apparently) booting into the desktop. I have a feeling it has something to do with NVCAP, but I even tried downloading my ROM and building a custom EFI with my NVCAP, and same result (black screen). In the end I just went an got a 9400GT MSI card, used an EFI string, and it works great. 1920x1080, QE/CI working fine.

j. Sleep doesn't work. Doesn't bother me.

k. System is rock-solid stable. No issues so far after a day or two of good hard use. Geekbench score around 8500 or so. Runs really fast. Something like 4x faster than my macbook pro 2.0ghz original old model.

l. I have updated to 10.6.1 using the regular apple software update, and it worked fine without touching a thing (no running of the script to update bootcaches, nothing, just worked).


OK I was going to write a bunch of stuff that I learned on the (very very) basics, like the EFI string issues re GFX, etc, but I've run out of time. Hope this info is vaguely helpful.

Link to comment
Share on other sites


  • Create New...