Jump to content

mkdir() failed to create /Library/Logs with error: Read-only file system


2 posts in this topic

Recommended Posts

I've tried installing iPC OSx86 10.5.6 on 3 different Dell PC's. This is my very first attempt with OSx86 of any kind, but I don't understand why I'm having this issue.


Optiplex GX270 (250GB IDE HD, 512MB DDR Ram, Intel 865 Chipset)

Optiplex GX280 (300GB Sata HD, 1GB DDR2 Ram, Intel 915 Chipset)

Optiplex SX280 (320GB Sata HD, 512MB DDR2, Intel 965 Chipset (I think))


I keep getting this error over and over again:


mkdir() failed to create /Library/Logs with error: Read-only file system


Disk loads fine, I have hyperthreading disabled in bios, and I've tried with and without cpus=1, and still get the error.


I've searched the forums, I can find a few times where others saw this issue, but no clear solution in my case (lots are using VMWare, but I'm doing direct single OS install)


After the error occurs numerous times, the installation decides it's ready to shutdown the system and shuts down.


Do I need to format the hard drives prior to install?

Am I missing something besides hyperthreading in the bios?

Do USB Keyboard/Mouse cause these issues? I'm thinking highly unlikely


I'm probably doing something very wrong. I've heard all these systems work very easily out of the box.


Please help, thanks.

Link to comment
Share on other sites


  • Create New...