Jump to content

Darwin/OSX Boot Screen and Networking

3 posts in this topic

Recommended Posts

I'm not sure if this is the right place to ask this, but i'm going to anyway =)


I installed Darwin on one of my PCs the other day. It's a Gigabyte GA-K8NXP-9 mobo (nForce 4 ultra chipset), Athlon 64, PCIe ATi Radeon x700.


I have a few questions about it...


Last time i installed Darwin was on a Beige G3. When this booted it had the cool Apple logo with the little round liney thing underneath it, but my PC doesn't have this, instead it boots like a classic *bsd system (or apple verbose mode) showing all the stuff thats loading.


I tried specifying it should boot into 'graphics mode' and also tried setting the graphics resolution, but to no avail.


Is it normal for it to do this?


Also the network doesn't work, i guess because there are no drivers for either of the NICs, however i read that someone had it working on a mobo very similar to mine?


Any suggestions on this?


One final question...


The PS2 keyboard doesn't work when booted into darwin, instead i have to use my Apple USB one. The PS2 one works to let me specify the boot options, but once started i need USB.


Also when it starts i get a message saying that the PS2 driver timed out waiting for the mouse, even though the omnicube should be telling it there is one there.


I also got rid of the annoying messages about not being able to load the nVidia drivers by removing the .kexts for them =)


Sorry about the long post, but i was wondering if someone could shed some light on my 'problems'.



Link to comment
Share on other sites

xboot does the logo, and it's there.


if you boot the cd with -F after an install, it will boot with the apple logo , ignore the bootfile and chroot into the system.


re: usb/ps2


it does work, but i found you have to boot with a ps2 mouse plugged in, otherwise the usb hotplug kicks in and takes over.

Link to comment
Share on other sites


  • Create New...