Jump to content

iDeneb v1.4 10.5.6 Root Device


11 posts in this topic

Recommended Posts



I was hoping that someone could give me a little help. I have looked around and tried different things but I can't seem to get this to work.


I just upgraded my computer and since it is amd I think it is because of that. My specs are:


Mobo: Gigabyte GA-MA790XT-UD4P

CPU: AMD Phenom II X3 720 2.8GHz Socket AM3

Memory: 4GB DDR3 1333

Video: XFX GS250XZDFC GeForce

HardDrive - IDE

dvd - IDE


And I tried to install iDeneb v1.4 (I have also tried 1.3, and some other versions, but all of them I have same issue).


I have booted it with -v so I can see what is throwing the error.


still waiting for root device


I put the disc in and start the installer and it stalls at this point and just continues to display it over and over. I have also tried -x but it doesn't seem to make a difference.


It also says this right before the root device:


firewire unable to determine security-mode; defaulting to full-secure


But I don't think this is stopping the installer from booting.


Thanks for any ideas on how to fix this!




Link to comment
Share on other sites

It's one or several of these:


iDeneb doesn't have boot support for your IDE/PATA controller (find out what controller your board has and find a OSX86 DVD that has support for it).


Your BIOS settings for the IDE controller are wrong


Try jumpering your DVD drive as master device on the channel and plug it in at the end of the cable.


It's probably a good idea to have the hard drive as master on its own channel/cable as well. Be sure to use a 80-conductor cable.





Link to comment
Share on other sites

Thanks for the ideas. I will try them out. My mobo only allows for one IDE so I am not able to do that option. (Guess that means it is time to upgrade those as well)


I did notice that once it enters the new screen after the initial boot, the dvd drive light doesn't blink at all.


Thanks, Ill let you know what happens.

Link to comment
Share on other sites

If you don't feel like buying a new HDD you could also get a IDE to SATA adapter and then use your HDD on a SATA port. Just don't buy a cheap and crappy one from Paraguay. :hammer:


Try unplugging the HDD from the IDE cable and see if it will boot the install DVD with your DVD drive jumpered as master and plugged in at the end of the cable.


If it works then you'll know what your problem is and you can stop trying to fix it at the software level.


I'm not saying that this is your problem though, it's just something to try.


Try other OSX86 DVDs, but find out what is the make and model of the IDE controller first.

Link to comment
Share on other sites

Okay! Well I have unplugged my hard drive and made sure the dvd was the primary master in the bios. I booted it this way (plugged in a flash drive so it didn't yell at me about no harddrive) and I still have an issue. So getting somewhere!


I looked up my mobo, is this my ide controller?


ATA100 2 Dev. Max


As I said I have tried several distributions already, think I have tried 4. Do you have any you might recommend to try?

Thanks again for the help!


Edit: I might have some other dvd drives laying around, could this help(they would all be ide)?

Link to comment
Share on other sites

It's not all about BIOS settings, the drive needs to be physically at the last plug on the IDE cable and the jumper set as Master.

That's not your IDE controller. Well it is but it doesn't mention the make or model, just the speed and how many devices you can connect to it.

Another DVD drive won't help you as it will be attached to the same controller.


Unless it is a SATA DVD drive.


I can't recommend any OSX86 install DVD without knowing what PATA controller you have.

Link to comment
Share on other sites

Yea I had it attached to the end of the cord and had it on master.


Well I have done some searching. I searched through the manual and a few websites. I havn't found much but on cnet I found this for my motherboard:




This is my south bridge and I am pretty positive it isn't the same as the IDE controller but I just wanted to make sure. Still searching, I will let you know if I find anything else.



Link to comment
Share on other sites

Good, you're on the right track. The drive controllers are part of the Southbridge.


The driver needed for your Southbridge is SB700.kext.


http://www.insanelymac.com/forum/index.php?showtopic=129235 (also check out the recommended BIOS settings in that thread)



(type sb700.kext into the search box for more).


You need to find an OSX86 DVD that has support for booting on devices that use this driver - or you can add it to an install DVD yourself using one of the methods you can find by searching.


Look up the release threads for the various distros, and you should find a list of drivers and fixes included on each.

Be warned though, just because see SB700.kext is included in the drivers list doesn't mean it's available during boot!

Link to comment
Share on other sites

Just to give an update. I tried that first link to try and put the SB700.kext on my iso. I have got several different errors now. I forgot to make the dvd the complete master, and the very first time, it loaded all of the drives, but when it changed screens, (the screen that shows for the -v flag), it became stuck and didn't display anything. I changed it so it would be the master, by using end of cable and using the correct jumper, and now I can't get it to even get that far. Sometimes it willl just restart and the other times it will display the error:


ebios read error: Device timeout

block 7018212


So I think I am going to try another ISO. So that will be another day or so!


Thanks for the help!


Edit: I just tried the original configuration and it gave the above error. Could this be a problem with the disc I burned?

Edit2: Okay so it does look like there was something wrong with the disc, but it is still just hanging when it boots. I think it is still having a similar issue though because the dvd doesn't flash at all. So I am going to try another install disc.

Link to comment
Share on other sites

Okay some updates! Since I have had to get a new iso, I have tried several other options as well, all along the same way. If you have any ideas on any of the different issues, let me know.


1) I got Kaylway 10.5.2. I tried it, and I tried installing the patch from that first link you gave me. Both of these discs will run through loading several "drivers" (when I boot with -v -x, other wise they restart after like 4 lines) and restarts after loading several drivers.


2) Now, when I installed the patch on the iDeneb v1.4 it switchs to the "debug" screen but it shows a few errors:


BSD process name corresponding to current thread unknown


And the last thing it says is something like


Darwin Kernel Version 9.2.0 Made by ToH: xnu-1229/Build/obj/Release 1386

(I can get a picture of this screen if it will help)


3) Lastly, this sounds like my most promising option.


I got a hold of a sata dvd drive from a friend, and I experiance the same as the above with the above discs, but if I use the iDeneb v 1.3 discs I have made I am able to get to the install screen! (before these were throwing the original error about the no boot device)


But here I run into an issue where my IDE hard drives are not showing up to select an installion path. I have 2 discs, 1 I have installed a patch on, and one that I didn't and they both do the same thing. So I am going to assume that the patch is not working correctly. So I am going to try and make sure I did the patch correctly on the v1.3 disc.



So, if you have any ideas let me hear them.


Do you think if I got a sata hard drive that it would work?

(I was thinking about a usb thumb drive, since I could try it now, but I think this will just create a bunch more problems I don't want to mess with)


Thanks again.

Link to comment
Share on other sites

wow, you sure put a lot of work into that. I'm sorry it didn't work out.


Like you say, when you boot from the SATA DVD drive and your hard drive doesn't appear, yes that's because the patching didn't work like it should. The hard drive is attached to the SB700 as well so that makes perfect sense.


Since you can boot with the SATA DVD drive it's pretty much guaranteed that you would see a SATA hard drive in the installer if you had one.


If you don't feel like shelling out for a SATA HDD (and you got tired of trying to patch your install DVD) another option is a PATA to SATA adapter.


USB drive - I couldn't say. Depends if the USB controller is supported or not.


I would still try to look for a OSX86 DVD that already has the SB700.kext on it - there must be some out there.

Link to comment
Share on other sites


  • Create New...