Jump to content

Firewire detection issues with Lacie Firewire 400 card


2 posts in this topic

Recommended Posts

Hi there,


I am having some problems with detecting my firewire card in retail vanilla Leopard 10.5.6


The annoying thing is, it was working ok up until yesterday, but now I get a red error message in system profiler (I can't remember off the top of my head exactly what it said, but it is to do with not being able to detect the card rather than detecting the card and a problem with a connected device).


I bought this PCI card about 2 months ago - a Lacie FireWire 400 card designed by Sismo - http://www.lacie.com/products/product.htm?pid=11161


When it was working and if I had my Presonus Firebox audio interface connected, boot times would increase, in verbose mode I got a security mode error and wondered if this was anything to do with it taking so long to boot, but made do with it at the time. This is something I'd also like to erradicate if/when I get the card working properly again.


I've tried moving the card to a different PCI slot but it still doesn't seem to detect it properly and I don't really know where to turn. I'm sure there may be a problem with one or more kexts I am running but any suggestions on where to go from here would be really appreciated. I've read a load of posts on here and elsewhere trying to decipher what might be happening, some people have mentioned trying to roll back the firewire associated kexts to tiger versions - is this a wise idea/necessary? Seems counter intuitive to me, but it if it works...I'm at work right now so will try out some stuff when I get home, but some direction from peeps here would be great :)


The only thing I can think that may have unsettled the card or firebox is installing windows 7 the other day and trying to get the audio interfaces drivers for vista to work on windows 7. Since then I have used the firebox on my Macbook though and it worked ok, so I can rule out a hardware error with that.


Any ideas?



Link to comment
Share on other sites

Ok I have got the card working again, not 100% sure how, but I'm sure it has something to do with Windows. It seems the problem stems from me trying to get the firebox to work on Windows 7 64-bit, as presonus are such a poor company they haven't provided a working 64-bit driver for this interface and I've been trying others' suggestions to get it up and running somehow...


Anyway, through the continual un/installation of drivers in Windows 7, it seems to do something to the device, and when I reboot and load up OSX the firewire card and thus the firefox can't be detected properly. But, if I actually shut the PC down and turn everything off for a few seconds then boot into OSX, the card gets picked up and works ok.


I'm still getting a very long pause while it seems OSX is trying to detect the firewire device, does anyone know if this can be reduced/removed? I seem to remember this happening on my macbook when it was plugged into the firebox at boot, although I'm not 100% on that.


I also get the full secure mode warning when booting in verbose mode, although this doesn't seem to affect it working, can someone explain what this actually means please?


Glad it's working again anyway! :wacko:

Link to comment
Share on other sites


  • Create New...