Jump to content

Sun Ultra 20 (not M2) up and running!


2 posts in this topic

Recommended Posts

Up and running now on a Sun Ultra 20 workstation. Note that this is not a U20 M2 and that the first version and the M2 only share a handful of cosmetic case components with the M2.


It's a bit of a kludge, as it quickly became a collection of hardware in order to enable this project.


Sun Ultra 20 (stock):

  • Tyan Tomcat K8E S2865 w/ nVidia nForce4
  • AMD Opteron 148 x 1gb RAM
  • Sun SATA backplane (to enable Sun Spud bracket use)
  • nVidia NV280 64mb card
  • 1x 80gb HD, 1x 250gb HD

Sun Ultra 20 (changes to arrive at current working config):

  • AMD Opteron 175 Dual Core (out of an Sun X2100)
  • nVidia 9600GT 512mb (also worked with nVidia 6600GT 128 from a coworker's U20)
  • Netgear GA311 (aka Realtek 8169)

Install from iPC PPF5:

  • 9.5.0 Voodoo Kernel
  • Legacy Time Machine Fix
  • NVIDIA MCP67 Drivers
  • Patched USB Driver
  • Firewire Mount Fix
  • IOUSBMassStorage
  • SATA Drive Icon Fix (New)
  • Seatbelt.kext 10.5.5
  • Shutdown/Restart Fix
  • Verbose Mode
  • AppleSMBIOS-27 Rev3 Mac Pro


  • Can't upgrade the BIOS with any of the Tyan-supplied AWARD/Phoenix utilies as it's a custom Sun BIOS. Latest version of Sun BIOS installed.
  • nForceLAN 0.62.13 panics system - earlier versions appear to work but will not route and there's no inbound or outbound traffic. I gave up and installed a Netgear GA311 which worked out of the box.
  • Natit_Dual_v0.02 was installed when the 6600GT went in to "see if it works." The 9600GT was installed and works out of the box (edit: not exactly as Natit_dual was already installed).
  • AC97 audio working (hacked kext for nForce chipset: http://wiki.osx86project.org/wiki/index.php/Audio).
  • Multiple drives work.
  • Time Machine works.


It's been running stable for over a week now but I reinstalled the 148 single core as the stock CPU fan ran annoyingly high with the 175 dual core (but boy was it snappy!). I've added another gb of RAM (2gb now) and it's running well enough that I cloned my corporate XP laptop and am running it in a VM.


Next step is to clone over the 80gb (boot drive) to a spare 250gb I've got.


Thrilled enough with it that I'm waiting on a Vostro A90 to show up and searching the office for another 2.5" drive to give it a spin on the corporate laptop in the meantime.


Thanks to everyone here as this place was the resource that made my install possible.

Link to comment
Share on other sites

  • 1 year later...



i have the same sun and when i changed with a dual core cpu and the fan ...

I solved my problem with linux and flashrom utility

Just download the latest bios of tyan and then run flashrom biosimage

After this only a few of change in bios and you can use your dual core...


I'm late about a year but i hope this post can be helpfull for you


Do you run hackintosh on this sun? I will try next days so if you have some information please share :)



Link to comment
Share on other sites


  • Create New...