Jump to content

HOW TO: Asus M50VM A1


3 posts in this topic

Recommended Posts



Hi everyone!

This guide is made for people who owns an asus m50vm a1 laptop. It might work for the whole m50vm serie but I can't guarantee anything.


What's inside the Asus m50vm-a1?

CPU Type: Mobile DualCore Intel Core 2 Duo P8400, 2266 MHz (8.5 x 267)

Motherboard Name: Asus M50Vm Series Notebook

Motherboard Chipset: Intel Cantiga PM45

Video Adapter: NVIDIA GeForce 9600M GS (1024 MB)

Audio Adapter: Realtek ALC663 @ Intel 82801IB ICH9 - High Definition Audio Controller [A-3]

IDE Controller: Intel® ICH9M-E/M SATA AHCI Controller

Network Adapter: Atheros AR928x Wireless Network Adapter


The tutorial

The version I used is iAtkos 10.5.5, you know where to get it ;)


Burn the iso at slow speed and make sure the iso is read only.


Boot up the cd and at the darwin booter press F8. enter the following command: -x -v cpus=1

Press enter and wait for the installer to boot. Once you get to the drive selection screen check in the upper toolbar for disk utility. Make sure you format your drive in MacOS Journaled format.


Choose the newly formatted drive and click next. On the next screen press the customize button in the lower left corner.

NOW! leave EVERYTHING like it is. The only thing you're going to change is SMBIOS. Switch it for SMBIOS EFI air.

Scroll down and go to System-> SATA/IDE -> Intel Sata


Note: These are the settings I used, maybe you can choose other settings but it might not work!


You can now install your OS and reboot after.


Okay, now when you see the darwin bootloader, press any key on your keyboard and type in the command: -x -v

With these you should be able to boot your OS. Make sure you have a USB keyboard and a USB mouse as your trackpad and laptop keyboard won't work (yet).


Fill in your info at the "Welcome screen" and connect yourself to the internet using a wired connection. It would be a good idea to download and install OSX86Tools and Kext helper.

First, we're gonna fix the keyboard and mouse issue.

Install both drivers from this thread then restart your computer with the same settings when booting (-x -v).


Next thing we're going to fix is the video card!

Download and install Aquamac's driver "NVIDIA 9000 Series Driver v2" with default settings.(Google it or check the forum). Once this is done, reboot in safemode (-x -v).

Next thing you're going to install is "NVdarwin Installer 1.2.5.mpkg" (again, google+forum) with the 1024mb setting. Reboot.

You should now be able to boot in leopard without -x -v commands


Now for the sound.

Look up for voodoohda.kext ver 0.2.2. Install it using Kext helper (just drag and drop the kext over the Kext helper application). Once this is done, reboot your computer!

Sound should now be working.


All in one card reader

The card reader works with this kext from this thread. Just install it with Kext helper reboot and voila!


Battery status

I tried different version of power management bundle and you best bet is power management 10.5.3. Look on google or the forum.


There are a few things that aren't working (or at least that I couldn't get to work). One of them is the wireless card. I just ordered a broadcom 4311 mini pci-e card from ebay, it costed me 20$ and is supposed to work "Out-of-the-box". If you got your wireless card to work well post it here :)


If anyone has anything they want to share about asus m50vm laptop and OSX86 please do it here. I'll keep this post updated with new stuff has I test things out.



-2 fingers scrolling. (tried FFscroll and it did not work)

-Fingerprint read.




-HDMI works! I tried it out this morning on my TV and it runs smoothly.

-Line in DOESN'T work :( I'll check for a solution, because being a musician I'm really looking forward to get it working. (I just bought a iMic for 40$ and it works perfectly).


Thanks to m0stw8nt3d for pointing me the sound, battery and Quartz fix.


I hope this guide will be useful. If you have any questions or progress post it here! I'm no expert but I'll try to help out.

Link to comment
Share on other sites

  • 1 month later...
  • 1 year later...

I'm sorry to bump this. But THANKS!!! It worked on my M50Vm-X1.


This is my 3rd attempt at hackintosh! now to get windows 7 and ubuntu back loading up in unison and the kexts installed.


BTW 10.5.3 power management killed my mouse and keyboard and had to resort to usb :)


Don't know yet how to fix that

Link to comment
Share on other sites


  • Create New...