Jump to content

Intalling OSX86 on a TC4200


3 posts in this topic

Recommended Posts

Hi Guys,


I am new to the whole X86 project and I have been trying to install it on one of my computers. The one I currently have, has received the install well according to other members of this and other forums, but for some reason, I haven't been able to install it on mine. The system specs are:



Hardware Overview:


Machine Model: ADP2,1

CPU Type: Intel® Pentium® M processor

Number Of CPUs: 1

CPU Speed: 1.73 GHz

L2 Cache (per CPU): 2 MB


Memory: 1.5 GB

Bus Speed: 533 MHz

Boot ROM Version: 68DTH Ver. F.0C (Hewlett-Packard)

Serial Number: xxxxxxxxxxxxx



Intel Graphics Media Accelerator 900:


Chipset Model: GMA 900

Type: VGA-Compatible Controller

Bus: Built-In

VRAM (Total): 256 MB

Vendor: Intel (0x8086)

Device ID: 0x2592

Revision ID: 0x0003



Resolution: 1024 x 768

Depth: 32-bit Color

Built-In: Yes

Core Image: Not Supported

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported

Acer AL1914:

Resolution: 1024 x 768 @ 75 Hz

Depth: 32-bit Color

Core Image: Not Supported

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported


I have tried using IAtkos v5i, Kalyway 10.5.2 and the latest is IPC 10.5.6 and none of them work. The one that gets me through the install process and them gives me an error is IPC 10.5.6, but I get the error in the picture below. Could someone get me a few steps to help me doing this install? I really want to get this computer to run Leopard, but I don't know how to.


Thank you in advance for any help you may be able to offer.




Best Regards,



I just wanted to add that I have tried connecting the external monitor and also the network cable. I also tried the 2 wire and 1 wire trick when installing the Kalyway 10.5.2 and nothing worked. I can install windows 7 beta and windows vista without a problem. Therefore, there is no hardware issue. Thanks again.

Link to comment
Share on other sites

Ok guys. I was able to install Kalyway 10.5.1 and I am even able to boot with the DVD in the drive, but I can't boot without the DVD. I have tried the below steps to fix the B0 Error, but nothing works.


My disk only has one partition and I formatter and mac os extended without (Journaled).


I have attached a screen shot of the terminal screen while I was doing these steps.


Can someone please help?


post-404182-1240277367_thumb.jpg post-404182-1240277379_thumb.jpg





The b0 error occurs on bootup, if no partition is active (or if you install GIUD drivers and are using MBR disk).


This basically means that the boot loader is not configured correctly.


To boot with the boot loader from the DVD, you need to know which partition/slice you installed to. If you do not know which partition/slice you installed to, boot from the install DVD instead


1. insert the OS X install

2. Hit F8 when invited to do so

3. Enter rd=disk0s1, or the partition/slice you installed to (in this example: first slice on first partition).

4. Once OSX has booted, make partition active and/or set the startup disk as explained below.


Setting the startup disk in OS X:


1. When you're in the installer Click Startup Disk from the Utilities menu

2. When booted from plain OSX Open System Preferences and click Startup Disk

3. Click the desired the startup Disk


To make a partition active, do this:


1. Start Terminal.app

2. Enter:

3. sudo -s (enter your password)

4. fdisk -e /dev/rdisk0 (the disk number may be different on your installation, eg. rdisk1)

5. print (list all partitions)

6. flag 1 (sets partition 1 as bootable - might be a different number on your installation)

7. quit (answer y to save settings)

8. Now reboot the computer. You should now be able to boot without the install cd. .


When this solution does not work, try this:


1. Start the computer with the CD. Wait until you can start the Terminal from the menu

2. Type this: fdisk -u /dev/rdisk0 (or any other number if it is not the first disk)

3. Quit the Terminal

4. Quit the Installer, a dialog box appears

5. Click "Choose Startup Disk"

6. Choose your first disk

7. Click Reboot

Link to comment
Share on other sites

I just wanted to give everyone an update on this. I had tried the suggestions I posted before without any luck and finally today while pocking around in the customization section where you select the drivers, I found the boot loader section. I had selected GUID and just for fun decided to change it to MBR and VIOLA... I fixed it.


I can now boot without the need to use the DVD.


Thanks for your help.


Link to comment
Share on other sites


  • Create New...