Jump to content

[SOLVED] Strange boot issue...more "Waiting for root device" grief.


2 posts in this topic

Recommended Posts

Hoping someone can help, this is driving me mental... I hate asking for help and usually prefer to figure these things out, but I'm at the end of my rope.



Problem: I can't boot from the iDeneb v1.4 (10.5.6) install I've put on my HDD.

I still get the 'Waiting for root device' error. Have spent literally a week partitioning, repartitioning, installing, reinstalling, switching hardware around, changing jumper settings, reading articles, testing different IDE cables (and positions), turning stuff on and off in the BIOS. Have exhausted the options in the 'Waiting for root device' page in the wiki, none of that works for me.


Now here's the odd part - I AM able to boot using the bootloader on the CD, and setting 'rd=disk0s2' as a boot flag (i.e. my Leopard partition on my HDD). Again, I can boot the install on my HDD using the boot manager on the CD, but not the one that I have installed on my HDD. Not sure what I'm doing wrong, and if anyone here can help I promise be their best friend...or at least, to thank them graciously and profusely.


A little more info:


Voodoo kernel ( is what I've been installing (seems not to crash)

Mobo: MSI 865PE Neo2 (ICH5 chipset)

Graphics: NVIDIA 6800 (not fully appreciated yet, of course - I need 1920x1200)

Sound: Creative SBLive! Value (&& onboard AC 97, && Creative Xmod - sound's not working though)

Wireless: WG 311T (Atheros chip, not coming up)

HDD: 80Gb IDE WD Caviar, set as 'Master'. I have two SATA HDDs but they are completely unplugged and SATA is disabled until everything else is going.


Anyone had this problem, or can suggest a solution? Help a desperate man out...please!


EDIT: PC freezes on shutdown and restart too...

Link to comment
Share on other sites

  • 2 weeks later...

For the benefit of anyone else suffering the same problem: Have fixed this.


The version of iDeneb I downloaded (1.4, which installs 10.5.6) didn't have the required support for my chipset, which is ICH5.


I downloaded one (actually a version intended for Tiger, but seems to work), booted into my OSX86 installation using the sneaky method described above, and then installed the new chipset driver. Root device was henceforth found.



Simple problem I guess, but most of the info on the net which relates to the "Still waiting for boot device" problem points to other solutions -- cables, jumpers, BIOS settings etc. After exhausting them over a two-week period, finally fixing this put a big smile on my face.



Hope it helps someone else with an ICH5 based motherboard who's been unlucky enough to start with iDeneb v1.4.


The End. Of this problem. For now...

Link to comment
Share on other sites


  • Create New...