Jump to content

Atheros kext won't load automatically


Farkonian
 Share

2 posts in this topic

Recommended Posts

HP DV9207us w/ Atheros AR5006EX wireless (I think?) Installed from iPC 10.5.6 Final DVD. Everything worked out of the box except the wireless.

 

Some quality time with Google led me to try several things, but I ended up loading Chun-Nan's IOPCMCIAFamily.kext and IO80211Family.kext.

 

Now the command:

 

kextload /System/Library/Extentions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext

 

gives me FULLY working Wifi with WPA2 support, configurable via the normal Airport tool.

 

My problem: I can't get the kext to load automatically during boot. I have to manually load it after the system boots.

 

I've tried creating a .plist file and putting it in /System/Library/LaunchDaemons/ with no luck.

I also tried putting a .plist file in /etc/mach_init.d/ again with no luck.

 

SystemProfiler says my card is "AirPort Extreme (0x168C, 0x58A)"

 

There was no line in the Info.plist file for 168c,5a so I added that line... but still no luck.

 

Any ideas? Thanks.

Link to comment
Share on other sites

Sometimes you just need to post in a forum to knock your brain free. :-)

 

I was only looking at the logs from dmesg, and wasn't looking at /var/log/system.log - The problem was my cards ID was in the Info.plist for AirPortAtheros5424.kext.

 

I deleted the line: <string>pci168c,58a</string> from that Info.plist and now the AirPortAtheros.kext loads during bootup like it should.

Link to comment
Share on other sites

 Share

×
×
  • Create New...