Jump to content

Deep Sleep Not Working! + other stuff: Asus P5W DH Deluxe


1 post in this topic

Recommended Posts

Okay, here is the situation:

I have

Current hackintosh: 

P5W DH Deluxe (AHCI SATA working with injector from chameleon)
Chameleon 2.0 (Most extra kexts are now in /extra/extensions)
XFX 8800GT XXX Edition + QE/CI working (factory overclocked, don't dare to flash Mac 8800GT Bios)
Onboard wireless: RTL8187L (working with official drivers from realtek)
Samsung Writemaster (DVD-DL Read/Write working)
1x 250 GB Sata 2.0 harddrive (partitioned into: 1st partition = OSX + Bootloader, 2nd Partition = Windows 7 Ultimate, formatted as MBR)
1x 80 GB Sata 2.0 harddrive (windows progs)
2xMarvell onboard Gigabit etherenet (8E....53 I think, working with stock appleyukon)
ALC 882M audio (onboard - currently experimenting with VoodooHDA)
Samsung Syncmaster 226BW flatscreen (running DVI - 1680x1050 - no lag except itunes+quicktime - solved by disabling upstreamuserclient)
2x1G Transcend 800mhz Dual Channel memory (added to smbios.plist)
E6700 @ 2.66ghz stock - O/C'd to 3.0GHZ with 1200 FSB (all cored detected  + working)
Onboard USB 2.0 working (USB fix for leopard)


I am running 10.5.6 with a patched DSDT from the GUI Dsdt patcher. The big problem I have is that I can't get it to deepsleep. I have tried messing about with sleep setting in bios, probably trying every combination possible, I have tried the command line to set the sleep from 1 - 10, I have tried teh deepsleep widget, but every time I just get normal sleep - i.e. the comp goes to normal sleep (with the light still blinking) this seems to happen quiet fast (maybe within 5 sec) so i doubt any information is saved to the hard-drive. I have read that other people have gotten deepsleep to work - any advice?


I also have a few other questions. First of all - I don't have dsmos.kext. What does this do? Is it necessary?


I have seen that some people have configured their GFX cards through EFI. How exaclty can you put EFI strings into DSDT?


The current disabler I have is from Iatkos 5i. It disables: EFINvram, EFIruntime, AppleHPET, INtelCPUPM and SMCplatformplugin. What is EFINVRAM and SMCplatformplugin. I have noticed that every time I boot I get an error message telling me that the SMCplugin couldn't load intelCPUPM. I have tried booting with IntelCPuPM enabled, but it freezes. Which of these are necessary?


I also have a problem that I can only resume from sleep with the power button - if I used the keyboard, the computer turns on, but then stays at a black screen until I reboot. Any ideas on this?


Another minor irritation is that in the System Profiler, no PCI devices show up, even though there are loads of them!


Sorry for all the questiosn, and if soem of them have been answered elsewhere, I am sorry i couldn't find answers ;)

Really appreciate any help! =)

Link to comment
Share on other sites


  • Create New...