Jump to content

iDeneb 10.5.5 installation: trying to resolve the "Still waiting on root device error"


1 post in this topic

Recommended Posts

Hi all,


I've been trying to install a variety of distributions for some time now and have not had much luck. After a few solutions, it looks like I'm running out of ideas. I'll outline my setup and problem below:


ASUS P5LD2-VM DH ACPI BIOS Revision 0501 (American Megatrends)


Intel Core 2 e6300


nVIDIA GeForce 9600 GT


Chaintech AV-710


BenQ DW1640-DD-DW1 (SATA)






WD 250 GB (SATA)


WD 250 GB (SATA: HFS+ partition is here)


Maxtor 120 GB (IDE)


USB mouse, PS2 keyboard



1. My first try at getting this to work was just popping the disk into the Benq DW1640 and I repeatedly got the error "Still waiting on root device.".



2. I then switched the disk into the DVDSKorea DVD-ROM and tried the following boot parameters and received the following messages:






AHCI enabled for all drives


platform=ACPI -v



Still waiting for root device


disk3s3: i/o error


SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x03 ASC = 0X11, ASCQ = 0x00


Jettisoning kernel linker.


Resetting IOCatologue.


kextd[47]: root filesystem is read-only; skipping kernel link data generation


localhost DirectoryService[53]:Launched version 5.0 (v514)


disk s3s3: I/O error.


SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x03 ASC = 0X11, ASCQ = 0x00


localhost DirectoryService[53]:Launched version 5.0 (v514): Couldn't find root user. Sleeping and trying again.



3. I then disabled AHCI and tried again from the DVDSKorea as the Benq would always give "Still waiting on root device" errors:


platform=ACPI -v


This resulted in loading like before and then a restart.

Does anyone have suggestions on what I could try next?


Thank you.

Link to comment
Share on other sites


  • Create New...