Jump to content

iDeneb v1.4 Problems


2 posts in this topic

Recommended Posts

Hi Folks!

I'm having some trouble with iDeneb v1.4.

I tried to boot with the DVD, but i keep getting "Still waiting for root device".

I have tried misc boot flags like "-f, -x, idlehalt=0, rd=disk0s1" but nothing seems to work.


I think that the hard drives are the problem. I have 2 hard drives, one IDE and one SATA. The IDE is FAT32 and the SATA is NTFS. I have tried with both of them as masters.


What am i missing? should i load some speceific kernels to have it working? Are there some other bootflags i should try?


Can someone please help me?


My system is:

Intel core 2 duo

Asus P5N-MX

Nvidia Geforce 8600 GTS 512mb




Link to comment
Share on other sites

Still waiting for root device

This is generally one of three things:

1. If you are using PATA (The old IDE Ribbon Cable Drives) you will want to make sure that the drive you are installing to is set to MASTER via the jumpers and the actual drive itself. Id also recommend that you have the drive on the cable's first connector.


2. If you are using SATA drives try going into the BIOS and changing the SATA Mode from AHCI to IDE.


3. Chipset related. If your booting the install disk and are getting this issue and the first two do not fix the problem its probably chipset related. In the case of SATA, some motherboards have more than one SATA control and so one or the other may be compatible. You can check your user manual or online to see if this is the case and then plug into the appropriate connector.



Ideally you should boot in Verbose Mode until you have your machine running the way you want. This can be done by using the -v boot-flag. When you start the computer up you will see the Darwin bootloader screen. This screen will count down and by pressing the requested key will give you a prompt to enter these boot-options. Now instead of getting a gray screen with Apple logo, you will get useful information about the boot process and see at which line it hangs on.


Other useful boot-flags are:

-f which will load your kexts (drivers) individually instead of from the cache file.

-x which will boot you into Safe Mode loading only the basics

Link to comment
Share on other sites


  • Create New...