Jump to content

Installing OSx86 Leopard in QEMU..please help!


3 posts in this topic

Recommended Posts

Hey, I've been trying for days to get osx86 installed. Why? Because I love it. I had it installed previously and it worked great. I really didn't have any troubles installing it back then either.


However, my dvd burner died, so I have no way to burn it/run from a cd. I've tried vmware and have had no luck. Soemone recommended QEMU. Starting it with the command "qemu -cdrom ideneb.iso -boot d" under linux works great. It starts right up..I got through a few things, but when it gets to the part where you format with the disk utility..it doesn't find any harddrive at all. Nothing.


I think there's probably some command or something I need to pass to qemu so it knows what my hd is, but im not sure what or how.


Help please! I've gotten so far..so close now..






Link to comment
Share on other sites

  • 5 months later...

You need to create a disk image and tell qemu to use that as well.


Use the following command to create the disk image:


qemu-img create -f qcow osx.qcow 10G


and then start it up with the command:


qemu -cpu coreduo -m 1024 -cdrom ideneb.iso -hda osx.qcow


You may want to change the 1024 to something smaller, depending on how much ram your real system has. You don't want to use over half of your memory for the VM, or it will kill your machine.

Link to comment
Share on other sites

  • 1 month later...

  • Create New...