Jump to content

[SOLVED] iDeneb v1.4 with 780G and SB700 Chipset


bboy_sonik
 Share

1 post in this topic

Recommended Posts

EDIT: Solved by using another KEXT I found and setting SATA to the non-native IDE port.... cheers!

 

Howdy guys :)

 

So I managed to get iDeneb v1.4 installed on an externel USB drive from another PC, and it boots and works on my ATi/AMD 780G based chipset (with SB700 southbridge) but I have a few issues, and i'm stumped... I tried searching the forums, google, wiki, no luck...

 

EDIT: Please read #3 first, if someone has an idea for me then ignore the first two as they are all related! =)

 

1) I tried to copy the USB partition to my internal IDE drive with Disk Utility, and it seems to work, but when I try to boot the partition it just gets a blank screen with flashing cursor. No error or anything. Do I need an MBR file to boot from rather than directly booting the partition? (I use XOSL) It is set as primary master, DVD drive as primary slave.

 

2) It doesn't detect my SATA drive, which is running in IDE native mode and configured as Secondary Master. I did make sure to check the ATi/AMD SB700 option during installation, and my IDE main drives are working as expect (fast) and USB is fine (iPod worked) and sound and network and QE/CI and EVERYTHING works 100%, except it doesn't see my SATA drive running in Native IDE... =(

 

3) I tried integrating the SB700 Extensions.kext onto my install DVD, but it resulted in a missing driver error when trying to boot from from it... hence why I had to use another computer and install on externel, because it was toooo slooooow installing (4 hours remaining) so I think I have a dodgy driver installed, prolly why my SATA isn't detected. I found that replacing the Extensions .kext file ONLY allowed it to boot, but it still showed my drives at 128GB size only and it was reeeaaaaly slow, so I think it did nothing apart from fix my "Still waiting for root device" it allowed my IDE DVD drive to detect, thats it. But when I also copied the "Extensions" FOLDER across and re-burnt, it gave me those errors about missing ACPI drivers or whatever. So could someone point me in the direction for either successfully slipstreaming these drivers on my install DVD (the original guide said they were tested with Kalyway, but I don't want to download another distro coz this one is supposed to be best for AMD), or, a page/guide on how to install drivers post-installation from KEXT's? The Wiki diesn't have anything...

 

Thanks so much guys, it's this storage driver and booting stuff that's the ONLY thing keeping me from totally enjoying OSX and learning more about it.... thanks in advance to all replies :D

Link to comment
Share on other sites

 Share

×
×
  • Create New...