Jump to content

BCM5787 - Anyone have one working with 10.5.6?


4 posts in this topic

Recommended Posts

I almost have this system running, but the network is driving me nuts. It is the only thing that is not working.


I'm using the Ideneb 10.5.6 install. The system is a MPC E-2610N.


Specs are:

Intel 945G Chipset

GMA 950 Graphics

Pentium E2140 Processor

80GB SATA III Hard Drive (Seagate)


ALC 888 Sound by Realtek (works with ALC888 V .1 and Kext Helper install)




If I can get this working I would be extremely grateful to anyone. I'm semi-using this as a demo computer as I do PC Repair so I can show people just how much alike Mac's and PC"s are (No, I don't recommend Mac on PC for anyone, just to show that they are much the same hardware wise for upgrades, etc..).


AGain, any help would be appreciated.

Link to comment
Share on other sites

It works on mine !!!

iDeneb 1.4 (OS X 10.5.6) at Acer 5920G

I'm using it to post this.



Try to enter




on the terminal prompt, and see if you have an en0 or something like that,


if yes, just check this: http://www.insanelymac.com/forum/index.php?showtopic=127903


Follow the Readme and install,

and it will work!


If there's not, (I was in this situation)

try to fix your IOPCCardFamily.kext and IOPCIFamily.kext.

I used this: http://www.insanelymac.com/forum/index.php?showtopic=134310


Solution 1:

You can find the files I used in Acer5920G.zip.

Don't forget to kill original these two kexts first,and then install them and do the same thing again as the following.


Solution 2: (I haven't tried it, I'm going now.)

Followed the direction on the bottom of that page.



However, because we're using different PCs, I'm not sure if it fits on your PC and if it will cause your PC crash or not.


Good Luck !!!

Link to comment
Share on other sites

The Broadcom5787M.zip that is in that post is what I decided to try last night on a fresh install. First I tried it w/ the Broadcom driver from the DVD that detects my network card and got a nice lock up and it would also lock on every boot.


Next I tried it with a fresh install with no network drivers installed and it was even worse.

Link to comment
Share on other sites

OK, I have no idea now :censored2:

Till now, my PC has had no error on boot with any drivers I installed.

So, I am afraid that I cant help you longer.

Hope you can enjoy OSx86 with someone else's aid!



Link to comment
Share on other sites


  • Create New...