Jump to content

IPC 10.5.6: The dreaded still waiting on root device...


Ozzu
 Share

4 posts in this topic

Recommended Posts

Alright, a little background. I tried a few other OSX86 packages and IPC is the only one that didn't give me the "still waiting on root device" error just booting off the DVD. I actually made it through install and went to my first reboot. I did the -f option like it said to in the readme and sure enough, I got the "still waiting on root device" error.

 

During the install, to prevent any confusion, I disabled my entire SATA system in my BIOS so that the install would never even see the drives attached other than an IDE drive that I have set as master and a DVD drive that I have set as slave on the same IDE cable. The HD is disk0s1.

 

During the install, these are the things I selected as customizations. I didn't choose much since I didn't want to have too much {censored} going on and confuse the situation further:

 

iPC OSx86 10.5.6 Base System

9.5.0 Voodoo Kernel

Via / Sis / Marvell / SB Chipset Drivers

Seatbelt.kext

 

I've tried the following things on the reboot at the prompt:

 

platform=X86PC -v

-x -v

rd=disk0s1 -v

-f -v

platform=ACPI -v

cups=1 -v -x -f -c

 

I get the same error. My system specs are as follows:

 

AMD Athlon 64 X2 6000+

Asus M3A78-T Mobo with the SB750 chipset (I believe this is most likely my issue)

4 GB DDR2 800 RAM

Nvidia 8800 GT 512 MB

 

I have my chipset device IDs if that helps:

 

PCI IDE Controller = Vendor is 1002 and Device is 439C

Serial ATA Controller (not sure this matters since I'm totally bypassing it as far as OSX is concerned) = Vendor is 1002 and Device is 4391

 

I'm somewhat at a loss here and I hope I provided enough information. Thanks very much.

Link to comment
Share on other sites

Tried some other chipset drivers like the micron ones, but no go. What gets me is that the install can see, mount, and write to the HD, but on the reboot, it just doesn't work.

 

So weird and so frustrating.

Link to comment
Share on other sites

 Share

×
×
  • Create New...