Jump to content

Some general noob questions on installing kexts and PS/2 Keyboard help


warmonked
 Share

3 posts in this topic

Recommended Posts

Hi, I'm looking for some help with getting my PS/2 keyboard to work. I've come across a few threads in the forums discussing getting PS/2 keyboards to work, but I haven't been able to get it to work myself. I'm wondering if I'm doing something wrong with loading the kexts. Also, I want to run my install procedure by you guys to see if I did everything correctly and understand what's going on. Thanks in advance!

 

My setup is:

Gigabyte GA-EG31M-S2

2x2GB DDR2-800

Maxtor IDE HD for OSX

PS/2 keyboard (Microsoft Internet Keyboard)

USB mouse (Intellimouse 3.0)

 

When I originally was trying to make my hackintosh, I tried Kalyway 10.5.2, where my keyboard and mouse worked fine, so I know it's possible for both to work happily. I couldn't get it to update to 10.5.6, so I eventually decided trying an install using my retail disk (which is 10.5.6) was probably the better way to go.

 

My procedure:

I installed using the "boot with boot132/swap to retail dvd" method (PS/2 keyboard never worked during install). After installation, I boot up w/ boot132 cd, then boot my OSX install at the prompt. Once inside, I loaded Chameleon_DFE_for_Hard_Disk, put the extensions from initrd.img from the boot132 into the extras folder of the Chameleon_DFE_for_Hard_Disk, and ran the pkg. This allowed me to boot up w/o the boot132 CD.

 

If I understand correctly, what's going on... Chameleon_DFE_for_Hard_Disk, is putting a bootloader onto the boot sector of my HD, that is able to load Kexts prior to loading OSX. This allows users to use custom kexts on their hackintoshes w/o ever touching the /System/Library/Extension folder. Is that correct?

 

So back to my PS/2 keyboard problem, I've been trying to load the ApplePS2Controller.kext or ACPIPS2nub.kext extensions that people have posted, by putting them into the Chameleon_DFE/Extras folder and re-running the .pkg. Is that a correct way of installing the kexts?

 

Thanks for any help.

Link to comment
Share on other sites

alright, I got it. loading the kexts by putting them in Chameleon_DFE_for_Hard_disk extras/ folder wasn't overwriting old kexts, I had to manually go into the EFI directory through the terminal and remove them before running the .pkg.

Link to comment
Share on other sites

 Share

×
×
  • Create New...