Jump to content

Airport Wont Stay On Help


2 posts in this topic

Recommended Posts

Okay, im sorry if this is easy solved. I have spent the last week and a half searching for a solution to my problem bc I was too scared to ask based on what I have read as responses to others questions regarding my wireless card.


I have an hp dv6000 laptop that I have whitelisted to allow other wireless cards. Also dual boot Leopard 10.5.5 and Windows 7.


I got a dell 1490 off ebay broadcom bcm4311, it works great and is recognized as a third party airport device. It will automatically connect on startup and I can use the internet fine.


However, after a few min sometimes 2 sometimes an hour. Airport will turn off and it will not turn back on.


Things I have done to try to fix this include


-taping off pin 20 bc I read that the hardware switch causes issues with this card, this did help in windows.

-I tried various power management bundles bc I thought this was causing an issue

-Pretty much everything i could find on this site about making the broadcom bcm43xx work in leopard I have tried


I have looked into doing this http://www.insanelymac.com/forum/index.php?showtopic=109613 but honestly I need some more guidence then I was able to pick up there bc I am a noob and not very good at running things in terminal. I have downloaded and booted a linux live cd though.


I ran pci utility and got this about the card


02:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11a/b/g [14e4:4312] (rev 02)

Subsystem: Hewlett-Packard Company Device [103c:1371]

Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+

Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

Latency: 0, Cache Line Size: 64 bytes

Interrupt: pin A routed to IRQ 16

Region 0: Memory at d6000000 (64-bit, non-prefetchable)

Capabilities: [40] Power Management version 3

Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)

Status: D0 PME-Enable- DSel=0 DScale=2 PME-

Capabilities: [58] Vendor Specific Information <?>

Capabilities: [e8] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+

Address: 00000000fee00000 Data: 4095

Capabilities: [d0] Express (v1) Endpoint, MSI 00

DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited

ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-

DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-

RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-

MaxPayload 128 bytes, MaxReadReq 128 bytes

DevSta: CorrErr+ UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-

LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <4us, L1 <64us

ClockPM+ Suprise+ LLActRep- BwNot-

LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+

ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-

LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-

Capabilities: [100] #14e4


Does anyone know how I should go about getting airport to stay on? Would being recognized as a real airport card help with this?


It also seems to stay on longer if my battery is not out, I am using voodoobattery.kext to get the battery monitor to display.





Link to comment
Share on other sites

Well I contacted the person I bought the card from bc this has been happening in windows as well. They just said something could have happened in shipping so I guess I will be sending the card back and hopefully the new one will work.


Anyone have any ideas?

Link to comment
Share on other sites


  • Create New...