Jump to content

Iphone not recognized via USB


TooTubular
 Share

2 posts in this topic

Recommended Posts

I don't know where to begin on this one. I've had this OSx86 going for sometime now, over a year, and all of the sudden, my iphone isn't recognized at all. The iphone is still seen fine in Windows and all other USB devices work fine in OS X. I've switched ports every which way with the same results so it is my assumption that it must be software based.

 

I've watch System Profiler when I connect the iPhone and there is no activity. I don't know what else to do.

 

Oh, and of note, I'm on 10.5.1. I'm not aware of an easy way to update (am afraid to ruin the pretty solid build I have going)

 

Update: Dug around, found the problem. Kernel Version didn't match the System.kext. I just hadn't thought of the proper way to vocalize my problem which later dawned on me, "Usb mounting". In any case, if someone has the same problem and finds this thread, check this thread out for a good place to start... http://www.insanelymac.com/forum/index.php?showtopic=95789

Link to comment
Share on other sites

I don't know where to begin on this one. I've had this OSx86 going for sometime now, over a year, and all of the sudden, my iphone isn't recognized at all. The iphone is still seen fine in Windows and all other USB devices work fine in OS X. I've switched ports every which way with the same results so it is my assumption that it must be software based.

 

I've watch System Profiler when I connect the iPhone and there is no activity. I don't know what else to do.

 

Oh, and of note, I'm on 10.5.1. I'm not aware of an easy way to update (am afraid to ruin the pretty solid build I have going)

 

Update: Dug around, found the problem. Kernel Version didn't match the System.kext. I just hadn't thought of the proper way to vocalize my problem which later dawned on me, "Usb mounting". In any case, if someone has the same problem and finds this thread, check this thread out for a good place to start... http://www.insanelymac.com/forum/index.php?showtopic=95789

Thanks! Just saved me a couple of hours work there, was wanting to start developing with my iphone and had the same problem, thanks :(

Link to comment
Share on other sites

 Share

×
×
  • Create New...