Jump to content

Trouble mounting EFI partition


Ego Tripper
 Share

1 post in this topic

Recommended Posts

So I finally got my first OSX86 system up and running, having installed Leopard with macanized's Gigabyte P45 boot-132 disc and a retail DVD. Then I thought it might be nice to streamline the boot process and maybe get some EFI strings going by booting from the EFI partition. So I started using munky's guide to do so, when I ran into some trouble installing the bootloader.

 

I was able to create the directory, but then I got this error message when I tried to mount the EFI partition to the point:

 

	bash-3.2# mkdir /Volumes/EFI

 mkdir: /Volumes/EFI: File exists

 bash-3.2# mount_hfs /dev/disk0s1 /Volumes/EFI

 mount_hfs: Not a directory

 

Information on the 'net regarding this particular error is pretty scarce. Does anybody know where I may have gone wrong or what I can do to fix this problem?

 

EDIT: I ended up bypassing munky's method (thx for the guide, though) and using EFIStudio to set up my EFI partition for booting. Great script! System now boots all on it's own.

Link to comment
Share on other sites

 Share

×
×
  • Create New...