Jump to content

First install = great success, trying again = fail?


tackle
 Share

5 posts in this topic

Recommended Posts

My system:

Core2duo, 4 gig ram on a Asus P5B (vanilla). 500gig HD on S-ATA port 1 with Windows, 320gig HD on S-ATA port 2 with OSX (or, I'm trying to).

 

Long story short:

 

I installed iATKOS v5i (10.5.5) on my computer. I did not even hit customize, just installed straight away, and it worked great. Got software update working and everything.

 

For various reasons I had to reinstall though.

 

So what happens? Install again, I get the dreaded "still waiting for root device", but this is AFTER installation which actually goes through without a hitch.

 

Needless to say, this led to extensive troubleshooting. I've tried every combination of Compatible, Enhanced and whatnot mode for IDE/AHCI. Tried unplugging the windows drive. Tried my target disk on all S-ATA ports.

 

However, I'm 99% sure of what all my settings before my FIRST (and successful) installation were, and I'm using those exact setting but it's not working.

 

I recall someone saying that if you can get the installation working, your system SHOULD work, at least when we're talking the root device issue. And I think it makes sense, but this problem does not.

 

This weird behaviour leads me to believe there's something essential missing somewhere, but I've tried every venue. Different GFX cards (although I'm not installing any GFX drivers until AFTER the first boot, so that shouldn't matter either). Enabling/disabling onboard LAN, audio.. no luck.

 

Can anyone make a guess, or suggest what I try next? I might end up buying a new motherboard if I can't get it to work, but in case there's something else hindering it (that a new MB wont solve), I thought it's worth a shot to ask around first.

Link to comment
Share on other sites

Good call, but no.

 

Unless someone broke in to my home and altered my computer somehow, this setup is identical.

 

I thought of one difference, and that is the first time I installed, the partition was initially Fat32 and converted to HFS with Disk Utility.

 

Second time around, it was already HFS, thus only "erased" in disk utility.

But I can't understand how that would make a difference though...

Link to comment
Share on other sites

Damn thing removed my post!

 

You mentioned about the filesystem being converted to HFS from FAT32, maybe its worth using an Ubuntu live CD with gParted to create a FAT32 partition then reconvert it? It doesn't make sense but it may just be worth a shot if it works - the disk utility might not be putting on the correct flags onto the partition table. Other than that it does sound like chipset issues - maybe there's a patch available for your particular SATA chipset? The other thing to try - and I know it sounds silly - is to reset the BIOS with the battery - I had an issue on mine and when I reset the BIOS it worked fine, so might be worth a shot.

Link to comment
Share on other sites

I've tried that now, same result.

 

Now I've also tried to completely erase the hard drive and all partitions, and let disk utility create it's own.

PLUS I tried doing the same, but having windows prepare an NTFS partition (whole drive) and erase that into HFS file system.

 

No difference, I might try the bios thingie but it nags me to death cause I've had the same bios all along.. ;)

Link to comment
Share on other sites

 Share

×
×
  • Create New...