Jump to content

Is this hope for HD4670 users...?


2 posts in this topic

Recommended Posts

Apologies in advance for the very long thread.


I have the PowerColor HD4670 (1GB with 2 DVI sockets) and have been trying in vain for the last couple of weeks (and months :rolleyes: ) in vain to get it to work properly (ie. QE/CI and acceleration).


Recently, I spoke to a few people on IRC and it was suggested that I try the latest natit drivers, but with Raven and Kakapo framebuffers (instead of the default Motmot one). I edited the info.plist to change all references from "Motmot" to "Kakapo" or "Raven" (obviously only 1 at a time).


I am relatively sure that I edited correctly, but when I booted with the kexts installed using kext helper, I got a kernel panic with either framebuffer.


For the purpose of allowing others to reproduce this (if you think you can get this to work, please try), here is what I did...


1) Downloaded latest link to 48x0 drivers for 10.5.6 ( http://is.gd/li8r ) (I was using iPC 10.5.6 release)

2) Extract the pkg file to my desktop, then open it with Pacifier and extract the kexts to a temporary folder

3) Opened natit.kext in finder (Right Click > Show package contents) and opened info.plist in TextEdit

4) Performed a find/replace on "Motmot" with "Kakapo"

5) Saved the new info.plist to the desktop, then dragged it into the kext in finder and authenticated.

6) Added the kakapo.kext ( http://rapidshare.de/files/46067210/kakaraven.zip.html ) to the temp folder

7) Used kext installer to install all the kexts (including modified natit) to System/Library/Extensions - new files:










8) Rebooted with -f to force rebuild cache.

9) PC will kernel panic on boot.


If you delete the kexts in single user mode and then try again with raven, I found the same happened.




When I tried again without modifying the natit (by accident), therefore using the Motmot framebuffer, I didn't get a panic or other error, but my display was blank and powered off (ie. monitor led orange after grey boot screen). The PC was running, and I could verify this by the HDD activity stopping after ~20secs and the standby button spinning down the HDDs, but no display. Every 10 seconds or so, the display led would go green and then orange again, much to my delight and then frustration.


Here is where I am just now:

I am using a Dell 19" TFT with only a D-SUB input and a DVI-VGA dongle to run it. When testing, I tried plugging this in both DVI sockets, and also put an 'empty' DVI-VGA dongle into the other port and the switched them around to no avail.


Could someone with a native DVI screen give this a shot (with the Motmot default framebuffer) and see if that helps, as I don't think I have one to hand.


Thanks, and hope this helps anyone who is interested in trying a bit of experimentation.


Credit to netkas, FunFactor and CycloneFr on #radeonhd channel on irc://irc.osx86.hu for most of this, but I rewrote it to try and spot any mistakes.

Link to comment
Share on other sites


  • Create New...