Jump to content

Intel DG35EC (G35) Guide

ganesh k

3 posts in this topic

Recommended Posts

Firstly , The bios settings..The Intel has recently updated the bios for this motherboard.Go and grab from the download center.



Secondly, If your using a Sata HDD please ensure you have connected to the first port that is the SATA PORT_0 and other peripherals to the next.

and In bios enable AHCI...It improves the performance too.


Remove Floppy Drive Function In Bios.


Now To the OSX86 OS That i have tested with right drivers..


Vanilla 9.5 works the best. In iAktos and iDeneb 10.5.5.


For the video kext read the following post




For Audio People have to stay with the Azalia Codec.But we have Hope For 5.1 channels and working inputs. I have tried lots of Codec Dumps from ubuntu 8.10 Live Cd by applying in Taruga's HDA patcher. The input and output gets recongized but still no sound. Right now i am on 45.5kbps internet soon i will be on broadband then i'll constanlly post my efforts.(codec dumps from knoopix and other various Unix OS's.)

Azalia Kexts are present in every modified OSx86 if any one need's the link can ask me.


For the Intel 82566DC Gigabit Ethernet Controller working with Intel82566MM Driver



orignally posted by slipttees of hackint0sh Group.


I have not tested the G35's IGP video coz im on nVidia 8600GT.With Nvdarwin and Nvinject working kexts.Soon i'll try that in holidays,coz still doin my high school studies.


Various Problems with Intel Dg35ec On Differnet OSx86.

1. iDeneb 1.3 10.5.5

This is the only MAc OSX OSx86 working flawlessly w/o any problems.(vanlill 9.5,apple azalia,nvinject)


2. iAktos 10.5.5

Donot select Voodoo kernel b'coz cpu accleration takes place were there is problem in watchig any videos on vlc and other.

there are less features in iAktos (like no dictionary, no extra voices)


3. iPc 10.5.6

9.6 vanilla kernel works but shutting down and restaring issue, so select shutdown and restart fix.

Anyone with motherboard has any problem can post...Thank You


Intel DG35EC Board

Intel Core2Duo 2.53@GHz-OOB

Ram 3Gb @667Ghz-Working

XFX 8600GT XXX -Working with Nvinject and Nvdarwin and with EFIstrings too.

ALC888S-Working only with Apple Azalia Codec.

Intel® 82801HB SATA ACHI controller = OOB Full Work

Seagate 1TB-OOB

Seagate 320GB-OOB



Intel 82566DC Gigabit Ethernet Controller-Intel82566MM Driver

Firewire and USB-OOB

Link to comment
Share on other sites

  • 6 months later...
  • 5 months later...

Hi, after two years of working in the osx86 world I´m still with my hackintosh.

My mobo intel DG35EC is working now with Snow Leopard 10.6.2

I still have shutdown issues

Still no HDA sound for ALC888S (not even with vodoohda)

EVGA 8500 GT 512mb

Everything else works fine


I have now a usb audio adapter that costs me 3 bucks on amazon

And a nice Genius Mac compatible cam islim 2000AF


Thats it, also the easiest way to install snow leopard for me was Empire EFI way.

Link to comment
Share on other sites


  • Create New...