Jump to content

Shuttle X27D iAtkos - Help Needed with Final Problem


6 posts in this topic

Recommended Posts



I'm hoping to get some advice from someone with a little more experience than I for the installation of iAtkos 5i on a Shuttle X27D Atom based PC.


The System:


Shuttle X27D


Processor: Intel ATOM 330 processor (Codename: Diamondville)


Chipset: Intel® 945GC+ICH7 Express Chipset


On-Board Graphics: Intel Graphics Media Accelerator 950 (GMA950) with PCI-E x1 improved bandwidth, features 333MHz graphics core


Memory: Crucial 2GB DDR2 PC-6400 (1 x module)


HDD: Western Digital 250GB SATA


NIC: Realtek 8111C


Audio: Realtek® ALC 662 6-channel High-Definition Audio


The Installation Distro


iATKOS 5i 10.5.5 Intel (tried Kalyway first but very prone to Kernel Panics)


Specific Installation choices;


iATKOS Main system

Kernel: PC_EFI V9


Remove PowerManagement



The Process:


This installation was a breeze and way more comfortable than the Kalyway I tried first. Created two partitions and use GUID rather than MBR.


Sound, network, applications all work "out of the box".


Very Cool!


The Problem:


Unfortunately the only sticking point has been the Graphics resolution. I see that the issue of the GMA950 has been discussed many times, both here and in other related sites. I have a standard 1024*768 resolution and there are no other available resolutions to choose from. I also have no detection of my Apple Cinema Display (20").


There are none of the mentioned artifacts on the screen and no tearing with cursor movement. I can edit the com.apple.Boot.plist file to increase the resolution a little but it still won't fill the whole screen.


Now, it may be that this is as good as it's going to get, but what confuses me is that the Kalyway installation provided many different resolutions and it worked perfectly with this screen (it just had no sound and Kernel Panic'ed about once an hour). Also, during the iAtkos installation it fills the entire screen with the correct resolution. It only seems to be after the final reboot that it reverts back to the fixed 1024*768.


Clearly in certain circumstanced this GMA950 can be configured correctly (as shown in the completed Kalyway installation and the primary stages of the iAtkos installer) but then something changes to limit the final resolution.


Does anyone recognise this behaviour or can anyone tell me how I might (a), get the GMA950 to pick up resolutions or (:), get system to recognise my display (and thereby give me more resolution options)?


I also have a Mac Mini, so am able to compare settings with another system that has resolution that works properly when combined with a GMA950 (as the Mac Mini does).


This is only my second attempt at getting this to work and most of my day is spent in a Windows environment, so some of what I have tried may seem foolish. Please bear with me, I am just beginning to get my head around what makes a Leopard growl :-)


I have tried the following;


[1]. Manually editing the com.apple.Boot.plist (some changes to resolution are effective).

[2]. Copying the bundle and kest contents for the GMA950 from the Kalyway installer and then re-registering using kext Helper.


[3]. Copying the same file set from the working Mac Mini and reinstalling with kext Helper.

[4]. Downloading and installing the GMA950 support package (referenced and linked elsewhere).


Those of you with more experience than I will know that at least two of the above resulted in the complete reinstallation of the iAtkos distro because the action simply broke the current installation.


As this seems the only remaining challenge I would really like to try and resolve it. Does anyone have any suggestions which might work please?




Link to comment
Share on other sites



Synaesthesia - Tanx.


I had looked at this and tried the instruction. Maybe I missed something. Will try again this evening.






Synaesthesia - Tanx.


I had looked at this and tried the instruction. Maybe I missed something. Will try again this evening.



Link to comment
Share on other sites

Hi All,


So, I tried the suggestion made by Synaesthesia ealier today. Unfortunately none of the patches worked and I am still left with a rather low resolution.


It is also rather unfortunate that this is where my "Newbie'ism" begins to show as it is entirely possible that I have applied the patches in the wrong way, in order to test this I need someone to explain the following about the process described in the link;




Using Kext Helper ....


As an example let's take the folder GMA950 V3;


[1]. Do I install these items one at a time or all at once, do I run through the list and then reboot after each installation?


[2]. Do I only install the files ending in kext and place the non-kext in the extensions?


Any help would be great.




Link to comment
Share on other sites

Here's an update for anyone trying to accomplish a similar build on the Shuttle X27D.





I have finally managed to get the graphics and monitor recognized and can get the full 1680*1050 on my Mac Cinema Display 20".


Here's how I did it.


The major install was accomplished through the iAtkos 5i installer DVD, prior to that I had tried the Kalyway 10.5.1 installer and met with limited (and unstable) results. But one thing that did work was the graphics card and monitor detection.


Back at my (almost) successful iATKOS installation I downloaded and installed Kext Helper and then inserted my Kalyway DVD. Once loaded I located the file "Extensions.mkext" in the location SYSTEM/Library/Extensions.mkext.


I loaded the file "Extensions.mkext" into kext Helper, supplied the sudo password and then clicked on "easy install". Once completed I rebooted the machine accepting the caution about the cache reload.


When the machine came back up the loader screen (the grey apple) stayed at the resolution it had before and I thought "bugger! another failed attempt", but once the loader completed and the desktop appeared it was in wonderful 1680*1050 and the display settings correctly identified "Cinema Display".


What followed next was a ten minute rave around the house, details of which are not really relevant here.


I hope that this forensic may prove useful to others trying the same thing.





Link to comment
Share on other sites

  • 2 months later...



Have you tried running PLEX media center on this configuration?

If so, any problems running HD video files?

Have you had any issued with the duo cores in the Atom?


Have you tried to upgrade to 10.5.7 ?


Thanks in advance!



Link to comment
Share on other sites


  • Create New...