Jump to content

Corrupt MBR, HFS+ Partition Error, etc...

2 posts in this topic

Recommended Posts

Hi everyone, I keep getting a HFS+ Partition Error when I boot my computer. I tried solving it using following some other guides here on the forum, but with no luck. Currently I can access OS X when I boot with the dvd.


My problems originally started when I was fiddling with Windows Boot Manager and somehow corrupted my MBR. When I tried to fix that I ended up unable to boot into anything. I tried several guides to fix that problem with Windows, but in failure decided to just format the partition and reinstall Windows. However now I can't reinstall Windows, because I keep getting the error, "Unable to find a suitable filesystem to install Windows on" even though I deleted and formatted the partition in NTFS and everything.


As a side note, when I tried to fix Vista and used the System Recovery Tool, it couldn't even identify my Vista installation (it was there though, I didn't accidently format it before hand or anything). Also when I tried to manually fix everything using BCDEDIT, I also got errors that a filesystem did not exist.


As far as OS X goes, I tried following these instructions: http://www.insanelymac.com/forum/index.php?showtopic=85163. Which are pretty much the same as all the other instructions I found on other posts on the forum.


After writing: fdisk -e /dev/rdisk0 I simply get brought back to the darwin dvd boot screen.


My current system is as follows:


1 Hard Drive


Partition 1: NTFS (currently blank, used to have Vista)

Partition 2: OS X iPC 10.5.5

Partition 3: HFS+ (partition for Home files)

Partition 4-5: Fat32 partitions shared between Vista and OS X

Partition 6: HFS+ (Time Machine)


So to sum up, 1) I can't reinstall Vista, 2) I can't boot into OS X without the dvd 3) I basically want to set it up so that OS X boots by default using Darwin, unless I specify to boot into Vista.


This has been driving me crazy since it happened. Any help is much appreciated!!! Thanks in advance!



***** RESOLVED *****


I was getting all the errors because I apparently forgot to switch the active partition when I was trying to do things such as fix Vista and so on. Once I did that all the other fixes I found on the forum worked.

Link to comment
Share on other sites

  • 2 months later...

have you tried the following solution?

Basically, Vista RTM foobars our working MBR's bootloader and you get "HFS+ partition error".

In following, I will assume we have one HDD with two partitions: part#1 = OSX and part#2 = Vista


1. Boot off OSX dvd disc in single user mode (press F8 and type -s)

2. At single user prompt

fdisk -e /dev/rdisk0

flag 1




4 reboot


At this point OSX should boot up, just like prior to Vista installation.

1 In a terminal window,

su root

fdisk -e /dev/rdisk0

flag 2


2 reboot


Vista will say "\Window\system32\winload" corrupted, and it will tell you to insert Vista disc and recover.

Follow directions from Vista and recover, then reboot. Check Vista boots and works fine.


1. Boot off OSX dvd disc for single user one last time (press F8 and type -s)

2. At single user prompt

fdisk -e /dev/rdisk0

flag 1


3. reboot

Link to comment
Share on other sites


  • Create New...