Jump to content

[solved]leopard takes a long time to boot


8 posts in this topic

Recommended Posts



I finally managed to get OS X up and running on my laptop, a HP Compag 8510w (see sig for specs), using iDeneb v1.3 10.5.5.

Well once booted into osx everything works perfectly (except for wifi, but there are no drivers yet, and the laptop freezes when i close the lid.). It's nice and speedy, sound works, can connect to internet with cable etc.etc.


But the problem is... it takes a VERY long time to boot. I haven't timed it, but it's prolly about 5-10 minutes. Once it's past the grey apple screen the screen just turns black, but with the backlight still on. After a while it will suddenly show blue (background image) and boot on till it's fully loaded and I can use the os.


I have searched around the forum for something similar but so far no luck in finding anything.

There is also no error messages (as far as i can see) because it happens after everything is loaded, so there is no message to see in verbose mode.


If anyone knows a possible solution, or a way to track what is taking so long, pleasee tell me. :(





[edit] oops wrong subforum... just one level to low :D [/edit]

Link to comment
Share on other sites

I had a problem with this when I first updated to 10.5.5. I am using XNU 9.4 kernel. I needed to specify what the front side bus speed of my system to com.apple.Boot.plist: fsb=800. (change out 800 for whatever is appropriate for your system).


If you look in "about this mac->more info->hardware overview" and look at the bus speed value, and it doesn't look right, then you need to use the fsb= kernel flag.

Link to comment
Share on other sites

Thanks for the reply.

I tried it, altough sys profiler was already showing the right bus speed of 800mHz, but it didn't work. It's still taking a long time to boot.

Not sure which kernel i'm using, can't remember what I picked at install and don't know how to look it up :P, but it's either 9.5.0 vanilla or 9.4.0 XNU.

Link to comment
Share on other sites

The first time I upgraded from 10.5.1 to 10.5.5 I picked 9.5 vanilla and boot time was so long I gave up before it booted all the way, so I never looked at the bus speed. I restored from backup and tried again with the 9.4 XNU kernel which booted faster (but still took 3-4 minutes) and thats when i found the bus speed flag and now my boot time is under a minute total.

Link to comment
Share on other sites



I know it's still in the wrong forum section, so reply's won't be as frequent I guess :wacko:


But does anyone know any other possible solutions? OR more importantly: how do I track what is taking so long?

just gonna save a system log... might be usefull :)


Ok I added a system log.

As far as i can see (judging by the times) it has something to do with these lines: (especially line 3 and 4)


Nov  6 00:55:45 roberts-macbook configd[14]: InterfaceNamer:   HP Compaq 8510w /AppleACPIPlatformExpert/C003@0/AppleACPIPCI/C0B0@1E/IOPCI2PCIBridge [2]
Nov  6 00:55:45 roberts-macbook configd[14]: InterfaceNamer:   HP Compaq 8510w /AppleACPIPlatformExpert/C003@0/AppleACPIPCI/C0B0@1E/IOPCI2PCIBridge/C257@6 [1]
Nov  6 00:55:45 roberts-macbook configd[14]: InterfaceNamer:   HP Compaq 8510w /AppleACPIPlatformExpert/C003@0/AppleACPIPCI/C0B0@1E/IOPCI2PCIBridge/pci1180,476@6,1 [1]
Nov  6 00:59:57 roberts-macbook /usr/libexec/hidd[57]: Timeout waiting for IOKit to be quiet 
Nov  6 00:59:57 roberts-macbook /usr/libexec/hidd[57]: IOHIDEventQueueCreate: Unable to allocate queue memory from IOHIDSystem. (0x10000003) 
Nov  6 00:59:57 roberts-macbook WindowServer[81]: Unable to create event queue via hidd: (0xe00002bd)


But it's not something I can fully understand, yet.


Link to comment
Share on other sites

Hi, guys,


Also have this problem with 9.4.0 XNu kernel but what ever I do it stays with 6 min boot, I installed on external USB disk, 10.5.5 i deneb install, is this problem because I have all that stuff just like you.. all stuff except PCMCIA on hp 8710p is working. it is depend on some component which is not installed?


Please help, 6 min is terrible...

Link to comment
Share on other sites

  • 4 weeks later...

Ok, I finally found a solution for this problem. My boot time is now about 1 min.


Just for other people that have the same problem here is my solution:


It seemed that the the thing slowing down the boot was the PCMCIA slot, which was needing drivers. The PCMCIA chipset in this case is the Ricoh RL5C476.

Lot of trial and error with testing drivers from this thread: http://forum.insanelymac.com/index.php?showtopic=81036

Many kernel panics later I found a set of working ones: IOPCCardFamily_chunnan_Leopard_rev8 (in the same thread as above)


Install procedure is basically backing up, copying new drivers, restoring permissions.


1. Make sure "IOPCIFamily" and "IOPCCardFamily are inside "System/Library/Extensions"

2. Open "Terminal"

3. Type "sudo -s"

4. Type "chown -R 0:0 /System/Library/Extensions/IOPC*"

5. Type "chmod -R 755 /System/Library/Extensions/IOPC*"

6. Type "touch /System/Library/Extensions"

7. Exit "Terminal"

8. Reboot the OSX


Credits go to Chun-Nan(~Eureka)


Worked for me, and hope it will help others.

Link to comment
Share on other sites


  • Create New...