Jump to content

iDeneb 1.3 10.5.5 on HP dv7 1060el


5 posts in this topic

Recommended Posts


I'm trying to install Leopard on my new notebook in signature.

In the textual screen of Darwin I have the usual problem of "still waiting for root device".

My bios is "castrated" and I don't want to lose the guarantee for my notebook.

What can I do? The use of a DVD USB it surely resolves the problem?

Does a patch exist for the dvd of installation, for intel chipset?




excuse me for my bad english.

Link to comment
Share on other sites

I hear around that we must install the prebuilt OSx on a master drive and a primary partition. The error "still waiting for root device" is caused by:


"Still waiting for root device" on boot to the dvd: Check your IDE cable on your dvd drive and try switching it's position to a different jumper location. If this doesn't work, you may need to look into a SATA or USB dvd drive.


"Still waiting for root device" on boot to the hard drive: Either you didn't install the proper ATA/SATA (hard drive controller) drivers/kexts, or your ATA/SATA chipset isn't supported by the disc you've used to install. If this happens with an intel chipset, try switching your BIOS options around from SATA or RAID to AHCI. This mostly happens with nVidia nForce, Silicon Image (SiS), VIA, and ATI/AMD motherboard chipsets.


The best ones practically guaranteed to avoid this problem faced by a lot of people is to (if you have the option) use an intel motherboard.


By the way, Im getting this error also. :Z Damn, we are so unlucky

Link to comment
Share on other sites

I have an HP dv5, and I used the iDeneb 10.5.5 from TPB. It boots into the DVD just fine I think, it has every time I boot with the -v option (one time if failed to boot, but I'm not sure if that was from the DVD or not).

I have a dv5 1098xx, which apparently is not an american model. What optical drives do you guys have? I have the blu ray one without lightscribe. As for USB booting, I am trying to install to a USB key, and the whole installation from DVD works, but when I try to boot from the key itself (the installed OS X) it has the root device error. I am about to try the option in the installer pertaining to USB to see if that fixes this, however, if you plan on installing to a usb hdd, you will want to enable that.

Link to comment
Share on other sites

  • 1 month later...

I have a dv7 1020 US.

(Core 2 duo 2.0ghz, P7350; 4gb ram; nvidia 9600M GT 512mb w/ hdmi and vga out; tv tuner; built in webcam; IDT HD Audio, eSATA)


I used the instructions outlined here


I started by updating my bios to f21 (latest from hp.com). This bios doesn't allow me to do anything really.

I used the macbook pro smbios. I'm not sure if this is a problem but system profiler recognized it as a macbook pro when I was doing the install. If I should reinstall with the macbook smbios, someone please let me know.


Some of the problems I have so far are as follows:

-No USB (this is a huge problem for me. Any ideas?) System profiler says there are 6 controllers installed

-I accidentally installed all NVDarwin packages so system profiler says I have 1024MB, I can fix this.

-I haven't thoroughly tested the audio, but it works. It can work better http://forum.insanelymac.com/index.php?showtopic=132495

-No webcam detected yet.

-Shutdown doesn't fully shutdown the computer

Link to comment
Share on other sites

I've since reinstalled. I now have most things working except for wifi.


I did not select any graphics or audio options. I selected the Apple Macbook SMBIOS.

I selected the fixes for USB, shutdown, and power management.

I believe that is all that I selected.


I followed the instructions at



Now ethernet, audio, video, usb all work. One strange problem I'm having is the webcam is recognized but only shows a black screen.


I assume HDMI-out doesn't work. I also assume that the blu-ray player won't work but I haven't tried either of those.

Wifi still doesn't work. I'd like it too. Supposedly I have the intel 5100 which is supported out of the box for some but not for me :)

Link to comment
Share on other sites


  • Create New...