Jump to content

booting issues...*sigh*


mbebop
 Share

1 post in this topic

Recommended Posts

SO-

got 10.5.5 running 100% the other day, everything working just so. decided it was time to do some house keeping in the bootloader; I had been using darwin to multiboot, but EasyBCD was configured from when I was using that, so there were still a few useless entries (one for OSX and one for linux, which is no longer installed) that I had to click through whenever I wanted to load windows. Problem with EasyBCD is it doesn't let you edit anything, or even open, unless windows is set as the active partition.

 

So no big deal, go through fdisk in OSX and set the windows partition active. windows boots up, I remove the two old entries, then use diskpart to set the OSX partition back to active, so I can continue to use darwin loader. Restart and lo and behold, "HFS+ partition error"!!! Tried booting with the Kalyway DVD in the drive, no luck, just tries to boot installer. Set windows back to active, tried repair HFS+ partition error repair in EasyBCD, doesn't fix it (big surprise). Tried adding a new OSX entry to the vista loader, only gives me a chainload error.

 

Now, I've had a problem like this before, and it seems to me to work like this; any time I edit the MBR in vista, there is a sharp pain in my {censored}, followed by a complete reinstall of OSX. Clearly I'd like to avoid this if possible, but I just don't know what to do. If anyone knows how to get me back into OSX, I'd love some help.

 

I suspect there may be an error with the Darwin bootloader itself, but I don't know how to reinstall the bootloader from outside OSX- if anyone has details on doing this (directions?).

 

I also have a fairly recent time machine backup, but I'm skeptical as to how well restoring will work. The restore function on mt Kalyway 10.5.2 DVD just doesn't work, and last time I tried restoring with iDeneb v1.3, it started loading up the backup and never finished. If any of you guys know of a restore DVD that works well, info would be appreciated.

 

Hopefully someone has an idea of how to fix this problem; I'm about ready to throw linux on here and try to grub it, but I get the feeling that's not going to fix HFS+ partition error.

Link to comment
Share on other sites

 Share

×
×
  • Create New...