Jump to content

[HOWTO] Gigabyte EP45-DS4P


1 post in this topic

Recommended Posts

Gigabyte EP45-DS4P


For those looking into EP45-DS4P motherboards - glad to report it works almost a 100%. All the motherboard features including 2xLAN, Firewire, and audio seem to work short of going to sleep at the moment which I haven't looked too much into yet. I've only had the Kalyway install sitting around which I set up using a vanilla kernel but I'm sure a retail install with a bootloader will work just fine (see the LS8 guide). The mobo is in many respects similar to the D6Q. I'll go into a bit of detail on how to get some things going, and in the meantime here is my setup:

  • EP45-DS4P
  • Q6600
  • 4GB of Mushkin RAM
  • Pioneer SATA DVD-RW
  • Radeon HD 2400XT (the dreaded 94c1)
  • Radeon X1950 XT
  • Linksys WUSB54GC wireless adapter
  • Mini Ninja heatsink (zero to do with Macs - just thought it's a cool name, mini NINJAAaaaa.... yeah)


I've tried SATA in both AHCI and RAID modes and they both work (haven't tried setting up an actual hardware RAID yet though - would be neat). All the BIOS settings aside from SATA were left as default. Installation was a simple as popping in the Kalyway DVD and installing off of it. Among the components I've chosen both the ACL889 audio and the rt73 drivers for my WUSB54GC wireless but neither worked after the install was done. Outside of that everything installed great and I even transferred all data from my MacBook via Firewire upon the first bootup.


Four things did not work out of the box - wireless, audio, my Radeon 2400XT (no kext loaded) and shutdown/sleep/restart. Let's do them one by one.



Kinda nice to be able to restart and shutdown. I used the OpenHaltRestart.kext though there is also the "classic" ACPI method. I tried both from karaakeha's guide and the ACPI way resulted in a kernel panic. I'll try it again tonight but for now OpenHaltRestart the way that works for sure. Here is how:

  1. Copy OpenHaltRestart.kext into your /System/Library/Extensions folder
  2. Go to Terminal (spotlight to the rescue! Command+Space that sucker)
  3. Type out: sudo -s and punch in your admin password
  4. Do this: chmod -R 755 /system/library/extensions/OpenHaltRestart.kext
  5. Then this: chown -R root:wheel /system/library/extensions/OpenHaltrestart.kext
  6. Ok, then: rm -R /system/library/extensions.mkext
  7. And lastly: kextload -k /system/library/extensions

That otta do it. That procedure is what you should follow any time you install an extension. All you're doing is setting the proper permissions: chmod 755 sets the file to be writable only by the owner and read-only for everyone else and chown changes the owner to the root user (the -R flag means recursively apply the commands to all files in the folder - after all extensions are not files but folders). And in the last two steps you're deleting the extensions cache and then recreating it.


Oh, and I really don't know why all those guides bother to use proper letter casing for paths - the default HFS+ partition is case insensitive, a nice break for any *nix user.



  1. Getting the WUSB54GC by Linksys running took a bit of searching but is fairly easy to get going:
  2. Download these two archives: One and Two (both are from this thread)
  3. Install #1, reboot with the -f flag, then install #2.

That's it. After the second reboot you should see the USBWireless utility and be able to connect to any network using either WEP or WPA. Hooray!


Audio (ACL889)

The EP45-DS4P comes with the ALC889a audio chip much like the D6Q. I've tried a number of extensions here and the ones that worked were all in the D6Q thread.

  1. Download the extension here (alternatively there is a supposedly pop free extension but I haven't tried it yet - haven't noticed any disturbing pops yet).
  2. Unpack the archive, that'll produce AppleHDA.kext and the HDAEnabler.kext
  3. Follow the same steps as in the wireless section above (ie. copy both into /System/Library/Extensions, set the correct permissions and reload the kext cache)
  4. Reboot and you should now have sound (check in System Profiler and the Sound pane of the system preferences). Time to put some of that Diana Ross on!

Radeon HD 2400XT

My graphics card, the Radeon HD 2400XT (fanless Gigabyte GV-RX24T256H - awesome for audio production work I'm involved in) took a bit of work but works great now. None of the extensions I found (the x2000 ones) worked for me - all I got was a bunch of random lines of screen and had to reboot in safe mode (-x flag) to get rid of the offending kext file.


So, what you do is you flash the BIOS with one for an HD 2400 Pro. Yes, the Pro is worse than the XT but come on, you weren't really planning on building a high-end gaming machine with that s**t to begin with were you? The original thread I found isn't terribly specific and I ended up f**cking up my Radeon's video BIOS, which is why I got a x1950 now, good for playing the many games on the Mac, such as umm... Dora the Explorer Animal Adventures I guess.


Anyway, here is what you do:

  1. Double-check you've got the right Radeon - click on the Apple logo > About This Mac > More Info and under Graphics check to see 94c1 is listed as the Device ID.
  2. If you don't have a floppy drive or a DOS bootdisk, get yourself an Ultimate Boot CD. Download the latest image and burn it on a CD. The nice thing about it is it's got FreeDOS which gives you NTFS and USB drive support. As you'll see in the next steps that comes in handy.
  3. Get the latest BIOS and the ATIFLASH utility. Make sure to get the BIOS for the 2400 Pro 256MB (in the release notes for the BIOS you should see the device ID as 94c3).
  4. Unpack everything and save it somewhere convenient. I used a USB stick which will work great if you have an Ultimate Boot CD or any other boot disc that supports USB devices.
  5. Load up from Ultimate Boot CD (hit F12 on POST screen to pick the optical drive) and go into Boot floppies > DOS > FreeDOS. In my case C: drive ended up being the USB stick, if that's not the case just type in D: or whatever letter name your stick is at.
  6. Navigate your way through to the folder with ATIFLASH and the BIOS's (if you're too young to remember the DOS days or have amnesia, use dir to list the files and cd [directory name] to move from folder to folder).
  7. Do this: atiflash -ai
    That will list all display adapters you've got along with some helpful info. Take note of the number of the adapter (one of the first things listed on the left). If you've only got one graphics card it will be 0. In my case the x1950 is 0 and the 2400XT is 1. Also make sure once again you've got 94c1 as the ID.
  8. Now run this: atiflash -s [adapter number] OLDBIOS.bin
    That will create a backup of your current video BIOS and save it under OLDBIOS.bin. If you screw up you can restore from it later, though you'll need another graphics card in your system like I do.
  9. Aight, we're all set. A deep breath and: atiflash -p [adapter number] [newbios.bin] -f
    Instead of newbios.bin substitute whatever the filename is of the 2400 Pro BIOS file. My guess your name will be ugly as it's probably more than 8 characters. Ah, DOS! :).
    The -f flag is there to force the BIOS in regardless of errors - on my card the SSID's didn't match and the utility seemingly errored out but upon next reboot everything on the screen was f**cked up which was inconvenient.
  10. Reboot. If you see the POST screen it's all good. If you see something else then call up your nerd friend and borrow a PCIe video card. Repeat the procedure, just replace the newbios.bin with oldbios.bin in the previous step.
  11. Boot into OS X. If you've already got the x2000 kext from a Kalyway install you should see that the resolution has improved and you can enable QE. To double-check, open up the System Profiler (under About this mac) and check under Graphics - it should give you information about the card now. If you haven't got the kext or everything looks the same ie. you can't change the resolution under the Display settings, read on.
  12. Get the x2000 kext. Edit the Info.plist to include the 94c3 device ID. This needs a separate thread of its own, and luckily for me there is one out there already - just follow this mini-guide for the 2400 Pro. Remember - now that you flashed the BIOS your videocard is a 2400 Pro, not an XT.
  13. Install the kext file like the guide suggests or do it the manual way I described in the Linksys wireless adapter section - I personally like to do things manually so I know what's going on, and I'm assuming you're nerdy enough too. How do I know that? Come ON, you're reading a freaking hackintosh guide! Eesh). Reboot.
  14. You should now have the video working properly. Time to enable Quartz GL for some EKSTREME GRAFiX. Save time and get the OSX86 Tools. Unpack and run them, and just click Enable QGL at the top left. To add Quartz Extreme check this link out. Basically you have to add the 94c3 to the Info.plist file. Easy-peasy! Reboot and wooow, it should all work.
  15. Mandatory step - while holding Shift press F12 to call up the widgets. WHOAA. It's like, widgets MATRIX-style dude! Trippy.

That's it. You should be up and running with the 2400XT now.




At this point it wouldn't hurt to backup. I personally use SuperDuper! because it makes very nice bootable backups. If you like it too you'll encounter a weird error on the hackintoshes as the program tries to erase your drives. It'll say _CFGetHostUUIDString: unable to determine UUID for host.


Just follow this short guide. Fixed the problem for me.



This is my second hackintosh and I'm quite happy. I've sold my MacBook and was waiting for Apple to come up with their new Air-like MacBook Pros but the specs on there turned out to be plain s**t so here I am, with a quad-core Mac for the price of a midrange MacBook. SCORE!


I'll try to keep this guide updated as I go along and install updates and other add-ons to make the system polished. Let me know if you find an error or just want to b*tch for no good reason.

Link to comment
Share on other sites


  • Create New...