Jump to content

Jas 10.5.4 on vmware-keyboard


13 posts in this topic

Recommended Posts

I downloaded Jas 10.5.4, and installed it on vmware workstation 6.5. (not beta)

I choosed os=other 64 and clicked:



Kernel Packages=stageXNU

all in plugin

all in device identification

all in older drivers

SMBIOS=mac pro



installation is ok, but after restart, it said "there is no keyboard connected...."

I searched by google, and found that maybe ApplePS2Controller.kext helps.

But I don't know how to add this .kext into jas' iso...

My host OS is XP. Could someone help me ?

Link to comment
Share on other sites

hi everyone!

i have the same problem with ps/2 devices... I also tried Googling, but everything i found was: ps/2 keyboard and usb mouse OR ps/2 mouse and usb keyboard... But i have ps/2 kb AND ps/2 mouse... I installed JaS 10.5.4 too. And when installing, there already is "generic ps/2 fix" or something like that, but it isn't working...


What can I do to work this out?

Link to comment
Share on other sites

I'm surprised to find that you can install a 64-bit OS as a VMware guest OS as your Host OS is 32-bit. It seems that VMware does not allow this.


In addition, there is another precondition. I have tried to install Leopard as a VMware guest operating system. I'm currenting running 64-bit Vista with a E2140 CPU that does not support VT (Virtualization Technology). But VMware Workstation requires that the CPU must support VT in order for a 64-bit guest OS to be installed sibe by side with the 64-bit host OS.


I know that 10.5 (Leopard) has 64-bit native support. I wonder if you are installing a reconfigured and revised 32-bit OS*86 10.5 (Leopard)version?

Link to comment
Share on other sites

You mean if we want to install a x64 guest OS, we need have a x64 host os??

I don't know this. My computer is ASUS A8JS, I think the CPU support VT.

I don't know if my iso is reconfigured and revised 32-bit OS*86 10.5 (Leopard)version, I just downloaded this from a very famous torrent site...

Link to comment
Share on other sites

That's how the VMware is reminding me when I choose "other 64-bit" for my guest OS. It says "64-bit guest operating systems are not supported by this host and will not run."


I ignored the warning and booted up the virtual disk anyway. But the installation hung at the initial stage, and could not go on. I have googled and it turned out that Mac Leopard actually has a 32-bit kernel. I wonder how you have made the ISO disk image successfully boot up and whether you have made any necessary change before the reboot.


I have tried two versions iATKOS_V2.0i and iDeneb v1.110.5.4 ISO[with PPF patch]

Link to comment
Share on other sites

  • 1 month later...

Someone already fixed the problem?

I'm getting the same probs on my Desktop and on my Laptop (XPS1330) with VMware 6.5 and Jas OS X86 10.5.4.

Strange thing:

On my Desktop I was able to connect the usb kb and the usb mouse to vmware. Same kb and mouse connected to laptop won't work with vmware. Only devices I'm able to connect are bluetoothreceiver, webcam and fingerprintscanner.


So if someone knows a solution including vmware and my integrated kb+touchpad I would be very happy to read about it.

Link to comment
Share on other sites

  • 7 months later...

I found a solution for this...

Simple put these 2 kext into /System/Library/Extensions and fix permissions... it worked for me and certainly it will work for everybody.

The big problem is: How can I put these kexts if my OS doesn't have keyboard or mouse working


Well... my solution was: I installed MacDrive (you can download a trial version on the internet, just google it) on my windows partition so it was able to see my MacOS HFS+ partition. Then I simply dragged the kext files to /System/Library/Extensions on Windows Explorer (ugh). Just by doing that my keyboard started working on leopard. So I rebooted on single user mode (just type -s at the boot process) and fixed permissions for the new kexts I installed.


Another option is to plug USB mouse and keyboard and install the kexts as usual inside the Leopard.


Or you can also boot from the Install DVD and using Terminal install the kexts too.


I didn't tried the other options, but they all should work.


OPS: I tried to upload the kexts, but it's failing for some reason. Just look for the ApplePS2Controller.kext and ACPIPS2Nub.kext on the forums... it's not hard to find.

Link to comment
Share on other sites


  • Create New...