Jump to content

[RISOLTO] Leopard Kalyway 10.5.2 su Sony Vaio VGN-N21M/W


molyland
 Share

8 posts in this topic

Recommended Posts

Finalmente dopo diverse versioni e prove quando avevo deciso di abbandonare è riuscito il dual boot leopard+vista.

Il mio notebook sony vaio VGN-N21M/W si presta ottimamente all'hackintosh, anche esteticamente visto che ha la linea plastica bianca :thumbsup_anim: .

Le caratteristiche potete vederle sul sito sony...

 

Ho installato la kalyway 10.5.2 partizionando il disco in 2 parti ( 40 + 60 GB ) con l'utility disco dell'installer di leo.

La partizione leo va formattata in gui journaled, mentre la partizione vista in fat.

Selezionate come gestore del boot MBR.

Installato leopard kalyway 10.5.2 con le impostazioni quasi di default, ho solo scelto la scheda grafica (intel GM950).

 

Poi ho installato vista sulla seconda partizione con un pò di fatica... non mi voleva vedere la seconda partizione.

Dovete avviare l'installazione di vista, riformattare la seconda partizione tramite vista, riavviare e quindi riformattare ancora la partizione per vista.

Credo che il doppio passaggio sia dovuto al fatto che la prima volta il MBR è ancora quello creato dall'installazione di leopard, mentre al secondo riavvio vista ha già modificato il mbr ( infatti leo non parte più ma non vi scoraggiate ).

 

A questo punto fate la bella installazione di vista, installate Easy BCD freeware e Mac Drive 7 trial.

Seguite la procedura che trovate sul forum ( http://forum.insanelymac.com/index.php?showtopic=95821 ) e vi ritroverete il vostro bel vaio con dual boot.

 

Okkio che in questo modo l'avvio funziona solo con l'alimentatore attaccato al portatile.

Poi una volta avviato leo potete staccare l'alimentatore.

Se provate ad avviare con solo la batteria vi si pianterà sulla mela iniziale e sfondo bianco ( boot -v -x mi da un errore acpi).

Link to comment
Share on other sites

poi ti meriti anche un altro + per aver messo nel titolo del topic : [RISOLTO] Leopard Kalyway 10.5.2 su Sony Vaio VGN-N21M/W, Installazione dual boot Leopard + Vista riuscita , finalmente iniziamo a dare buon esempio bravo!

Link to comment
Share on other sites

Grazie dei complimenti, è sempre un piacere contribuire.

Confermo che dai test il pc risponde proprio bene, ma sono ancora agli inizi.

 

Vi accenno alcuni piccoli disturbi, non viene riconosciuta molto bene la batteria,

l'avvio senza alimentatore non funziona, si blocca sulla mela e sfondo bianco, ma non disperate,

lasciate l'alim e ad avvio completato potete tranquillamente scollegare l'alimentatore.

 

Secondo disturbo, non va il quartz extreme anche se ho aggiornato i driver.

La scheda è una GMA 950 o 945, sull'etichetta è scritta la prima ma sia vista che osX86 tools me la vedono come GMA 945.

 

Terzo disturbo, le periferiche usb le devo attaccare da spento, a caldo non le rileva.

 

Vi aggiorno se riesco a correggere questi difetti.

Link to comment
Share on other sites

Azz .. ho inserito l' AppleACPIPlatform.kext e il PowerManagement.bundle, risultato...

Il pc fermo sulla mela con sfondo bianco e la ruota di caricamento in corso ..

Tentato avvio con -v -x ed ecco il risultato :

 

img.jpg

Link to comment
Share on other sites

Nuovo aggiornamento...

Ho risolto il mancato avvio dovuto al kext dell' ACPI cancellando a mano l'estensione da windows con il programma mac drive 7. A quel punto leo si è avviato correttamente, ma ovviamente mi scriveva l'erroe che mancava un kext.

Ho provato a correggere ripristinando i permessi con osx86 Tools e adesso non mi parte più.

Al caricamento della mela mi da l'errore della finestra multilingua...

Link to comment
Share on other sites

Aggiornamento :

 

Rifatta l'installazione Kalyway 10.5.2

kernel sleep

scheda video intel gma 950

al riavvio aggiornati i driver audio e video con osx86tools

 

Tutto funzionante, compreso Q2D e QExtreme

punteggio Xbench 99.6

 

resta solo da sistemare il difetto usb

Link to comment
Share on other sites

 Share

×
×
  • Create New...