Jump to content

[Guide] Installation on Gateway MT6705 Laptop


8 posts in this topic

Recommended Posts

I have received a good few PMs regarding getting the MT6705 to work good under Leopard. I have just been replying through PMs, and I figure there are more people that are using the same hardware that just don't know to contact me about it. So, here is a guide for the rest of you.


Official Hardware Information: http://support.gateway.com/s/Mobile/2007/O...shtml?rdr=v1403


In a nutshell, this laptop has:

-Intel Core Duo T2060 @ 1.6GHz

-STAC9250 audio codec (IntelHDA)

-GMA950 Video

-ICH-7 AHCI (SATA controller)

-Synaptics Touchpad with Sidescroll

-TI xx12 PCMCIA Card Reader

-RTL8187 Onboard Wireless NIC

-Marvell Yukon Gigabit Adapter 88E8053

-Motorola SM56 Modem

-4-in-1 Card Reader


This guide WILL NOT SUPPORT the Motorola SM56 Modem, or the RTL8187 wireless. The reason for the modem is that, well, I have not been able to figure it out and, even if I did, I have no way of testing it. I don't think that actual Apple hardware has onboard modems, which makes it difficult (or impossible) to get working without official drivers. The same goes for the 4-in-1 Card Reader. The RTL8187 drivers that Realtek had released only supported OSX Tiger and, last I checked, was not released for Leopard. The Tiger drivers somewhat worked, but would cut out within seconds after connecting to a network. I gave up and got a Dynex DX-BNBC for about $30 at Best Buy, which has the BCM4318 chipset in it. This means that it is supported and seen as an Airport Extreme card.


Something to note, concerning distributions of Leopard, is that iATKOS v4i seems to me to be the best suited distribution to this hardward. However, I have never had luck with it actually installing a bootloader. What I found out I have to do is install iATKOS v4i as normal, which entails:

-Preferably formatting the hard drive as GUID

-Installing with the following selected:

-the SATA driver package (not nForce)

-the GMA950 drivers

-vanilla group (stock Kernel + stock ACPIPlatform, if I remember correctly)

-Darwin bootloader.

Once it is installed, I have to insert another distribution DVD at boot (I chose Leo4Allv3), letting the time wind down to boot the DVD, and let the bootloader on the DVD boot the hard drive. Once booted, I have to install Chameleon v1.0.11 via the installer package from the official website.


This should work with any other distribution, but updating is easier from iATKOS v4i due to being at 10.5.4 to begin with. This guide will only cover a distribution starting at 10.5.4.


So, anyhow, on to the guide. Please remember to read through this guide before attempting.




First, download this ZIP: http://www.mediafire.com/?q0wzujylwlr - MT6705.zip

It will be beneficial for you to copy this to a USB drive before continuing.


1) Install iATKOS with the options outlined above. When the installation reboots, remove the DVD and see if the bootloader installed. If it did not,

1a) Insert another distribution DVD (I'm sure you have one laying around, right?) and wait for the DVD's boot screen to come up, and then time out. At this point, it should be booting your installed OS.


2) Go through the first time setup information. Afterwards, insert your USB drive. If you have not already, unzip MT6705.zip. It's location is not too important, so long as you have access to it later.


3) Open "Chameleon-1.0.11-installer.dmg" and double-click on the "Chameleon_V_1.0.11" icon. Follow on-screen instructions. Make sure to install it to the partition that Mac OS X is installed to. If it prompts to reboot, you may after removing any DVD in your drive if you wish--but I would wait until after the next step, since these two steps do not interfere.


4) Open "Kext Helper b7". Drag and drop the following files into the program's window:

-IONetworkingFamily.kext (enables your Yukon 10/100/1000 card)

-IOPCIFamily.kext (in part enables your PCMCIA card reader)

-IO80211Family.kext (optional, if you have the Dynex DX-BNBC card)

-IOPCCardFamily.kext (in part enables your PCMCIA card reader)

Enter your password, and click "EASY INSTALL". It will prompt you to reboot, so go ahead.


5) Once you return to your OS, go back inside the folder and open "AppleHDAPatcherv1.20.app". Drag Sigmatel9250.txt into the application window, and let it do its work. It will prompt to reboot, do so.


6) Once again back in your OS, download the 10.5.5 Delta Update, available at: http://www.apple.com/support/downloads/macosx1055update.html

Once downloaded, follow these instructions: (from http://insanelymac.blogspot.com/2008/09/ho...for-osx86.html)


sudo -s


*type password*


while sleep 1;

do rm -rf /System/Library/Extensions/AppleIntelCPUPowerManagement.kext; done


Open 10.5.5 Update Installer




Go back to your terminal and press Control C to end the script


In terminal type:


nano /System/InstallAtStartup/scripts/1


Replace the line Dont Steal Mac OS X.kext with dsmos.kext (this line may or may not exist, it did not for me)


Restart and boot with -v



7) If you need to, repeat steps 4 and 5. Sometimes updates will overwrite kexts.


8) Now that you're updated, open "Kext Helper b7" again. Drag and drop into the application window:

-IntelEnhancedSpeedStep.kext (for Speedstep)

Enter your password, and click "EASY INSTALL". It will prompt you to reboot, so go ahead.


9) Once back in your OS, copy "SpeedStep.app" to your Applications folder, and then add to your dock. Once it is on your dock, right-click and select "Open at Login". Go ahead and run the program. You will see a number appear and fluctuate at the top of your screen. This is the speed of your processor, telling you that SpeedStep is working.


10) Finally, run and install "Power Management 10.5.3.pkg". Once installed, reboot. Once rebooted, you will see the battery meter at the top of your screen.


11) If you wish to use the sidescroll on your touchpad, browse out to /System/Library/Extensions, go into ApplePS2Controller, browse to Contents/PlugIns/ and delete ApplePS2Trackpad.kext. Reboot, and viola! Your sidescroll works perfectly. This works because the OS doesn't think it is a Trackpad, and thus treats the sidescroll as a mouse wheel. This takes away touchpad settings, but I'm sure you wanted tap-clicking and dragging anyhow, right? :blink:




Once again, for the sake of quick reference, here are download links:


http://www.mediafire.com/?q0wzujylwlr - MT6705.zip (MT6705 Drivers)

http://www.apple.com/support/downloads/macosx1055update.html (10.5.5 update, for updating from 10.5.4 only)

Link to comment
Share on other sites

I own a MT6705, too. The Realtek 8187 still working with some little problems from startup this card. Of cause, hackintosh did not receive it as an AirPort Card. In spite of its deepname is 8187B, I used the 8187L drivers from Realtek download drivers page. It works perfect and I don't know why.


The input sound is low and some time, with a call, I must shout loud :) I didn't find any option to increase the volume of the input.


I have a little problem with the sleep feature. It slept well, but on wake up, the text or any front list (icon list, folder list) scroll up until reach the top of the list. I must change to Finder and create a new windows to stop this inconvenient. How to put the computer to sleep when closing the lid? It only sleeps the display.


When I connect the laptop to the projector using the VGA port, the two laptop and projector displays confusion. I changed the number of colors, change the display size (800x600...) but it still. From restarting the OS, the projector display right until logon to the desktop, the display confusion appears.

Link to comment
Share on other sites

Yeah, I've only ever gotten RTL8187 to work in Tiger. I kind of gave up because I was able to afford the PC card.


Sound input... yeah, its low. On Skype, I have to pretty much eat the microphone, but the person I am talking to can hear me. I am kinda working on that, but I'll probably get a USB headset.


Sleep I have never really focused on. Its not a big deal for me. In the past, I have tried sleep kernels. All that happens is my screen goes black--not like monitor turned off black, but like input black. I end up having to do a hard reset to restore operability.


As far as VGA output, I have always had good luck. Never tried a projector, but tried a 14" monitor that runs 1024x768x32@60Hz and its fine. Can't do mirror correctly because my laptop screen is 1280x800, but it would work if I hooked up to another monitor that supported that resolution.


One time I was messing with drivers and that whole screen confusion thing you're talking about happened. I ended up reinstalling. It only happens when there is another monitor/projector connected, right? I think it all went wrong when I hit Fn+F4 (switch screen?). As long as I don't do that, I'm fine.

Link to comment
Share on other sites

The displays errors may only occurs with a projector. I've tried a monitor 17'' and it'd worked fine. I think the problem is I've changed the default color profile or something similar. I'm using kalyway 10.5.2 and considering carefully to upgrade to 10.5.5. Someone warned me the system maybe down if not upgrade careful. Can I upgrade directly from 10.5.2 to 10.5.5? Also, i'm looking for driver for 4-in-1 card reader.

Link to comment
Share on other sites

The bad news is that, unless you know how to make drivers, or know someone who does and will, the 4-in-1 card reader will not work. Since Apple never equipped their computers with one, there is no driver. Some card readers will work on some systems if they are attached to the USB bus, however ours is on PCI, direclty attached to the PC Card reader (PCMCIA).


My solution was to get a card reader made by Targus, its like a 3-in-1, that plugs into a USB port and accepts a card. It only costs about $8 at Kmart. It is actually a great idea if you do USB booting (linux OS, bootloaders, etc) because you can just switch out the card, and the cards are cheaper than USB sticks.


As far as upgrading is concerned, the safest way is to go from point-release to point-release. Look around, I am sure theres a guide or instruction of some type. I would back everything up and get a latest distribution (iDeneb 10.5.5?), but thats me. I am more comfortable wiping things out and starting fresh.

Link to comment
Share on other sites

  • 3 months later...

Great guide, I have owned one for a while and experimented with OS x86 since the deadmoo days (and bricked the original hard drive in the process). I have successfully modded everything about it except the BIOS, and Gateway does not seem to provide any links for a BIOS download whatsoever. Has anyone gotten a new BIOS to successfully flash (and therefore boot) on this laptop, so I may replace the bootsplash?

Link to comment
Share on other sites

Great guide! I have found most of this the hard way, but sure is a great thread to come back to if I ever brick it again. Just a note, I am running a MT6821, which is pretty much identical, except for the addition of the firewire (if you don't have). The one thing that the pcmcia does do is break the firewire, so I must choose pcmcia or firewire. Other than that working great!

Link to comment
Share on other sites


  • Create New...