Jump to content

Yet Another USB Problem

3 posts in this topic

Recommended Posts

Wow, I really hate to start a thread for this, BUT after spending 2 whole days scouring this forum for someone who has already had and solved a problem similar to my own, I'm finally yelling "uncle".


Now, one thing I kinda noticed was a horrific lack of information when someone was crying for assistance... more often than not, along the lines of "My {X} does not work! Plz help!"


SO, I'm going to try to provide as much relevant information as possible to try and help prevent those that know what they are doing from feeling like they are being placed in a mental torture chamber.


I installed the Kalyway 10.5.2 DVD (after checking the MD5 sum) onto my 3 year old IBM (Lenovo) ThinkCentre A51 (8131-1SU) and except for a quick jaunt with my Video Card (stupid me, bought a non-standard card that was wreaking havoc, replaced with 8800GT) everything went smoothly and everything works GREAT!


Except my USB.


Now, first off, low and full speed USB devices work peachy, so long as they are not storage (Aka, keyboard/mouse, webcam, iPhone, iPod, bluetooth, PowerMate, etc...)


High Speed USB (2.0) has no hot plugging what-so-ever, as in anything USB 2.0 that is plugged in after boot is flat out ignored by my Hackintosh.


That said, if the USB storage or 2.0 device is plugged in at start up, it's all flowers, butterflies, happy, happy, joy, joy.


Now for the technical parts.


I have tried to get hot plugging working with legacy USB support in the BIOS enabled and disabled. I have also tried it with "Plug n' Play OS" enabled and disabled.


I am getting sucess in the OS grabbing control as per suggestion in another thread:

Oct  8 00:04:25 localhost kernel[0]: Extension "com.apple.driver.AppleACPIPlatform" has immediate dependencies on both com.apple.kernel and com.apple.kpi components; use only one style.
Oct  8 00:04:25 localhost kernel[0]: USBF:	0.425	Attempting to get EHCI Controller from BIOS
Oct  8 00:04:25 localhost kernel[0]: USBF:	0.425	USBLEGCTLSTS value c0080004
Oct  8 00:04:25 localhost kernel[0]: USBF:	0.425	Found USBLEGSUP_ID - value 0x1 - writing OSOwned
Oct  8 00:04:25 localhost kernel[0]: USBF:	0.425	acquireOSOwnership done - value 0x1000001
Oct  8 00:04:25 localhost kernel[0]: mbinit: done


And if I plug in a 2.0 or stoage device after booting, the device shows up in the "normal" USB devices area, not the high speed and DOES NOT work.


After removing the 2.0 device I recieve this notice in the system.log via the console:

Oct  8 00:52:20 XXXXXX-mac-pro kernel[0]: USBF:	2880.228	AppleUSBHubPort: Port 1 of Hub at 0x3d000000 about to terminate a busy device (U3 Titanium) after waiting 10 seconds


Ok, software out of the way, now for the hardware. My motherboard in this uses the Intel 915G Chipset for the north bridge and the Southbridge is a ICH6 (also Intel)


I also figured OSx86 just hated my board's built in USB, SO I nabbed the 5 Port PCI USB 2.0 card (NEC Chipset) from my aged Quicksilver that has worked flawlessly with OS X for years, toss it in, lock it down and boot up my hack mac again to find...




It's not even being recognised, put it back in my old Quicksilver and no problems to be found, it still worked beautifully.


So, I'm stuck between a rock and a hard place with no real USB support and just looking for some assistance to get my temporary Hackintosh upgrade completed!


Thanks a ton in advance!

Link to comment
Share on other sites

had to dust off this link but in the old days we got some help from apple ;)



just install and read the read me file



this link if the above link does not help you with usb trouble:


try all at your own risk

Link to comment
Share on other sites

Oh my god THANK you! :blink:


The second solution worked perfectly and my Hackintosh is fully operational at long last! :)


I must have somehow missed that particular thread while I was hunting, which was why I hated to start a new one, because I was quiet certain that it had been brought up and solved at least once before.




There is no way I could possibly afford a new MacPro right now which was why I finally chose to tackle this project which left me with a (now) fully operational and fairly snappy Hack Mac for a total of $210 (+2GB of RAM, 500GB HD, 8800GT)


Now I'm off to hunt down a thread regarding if late Generation P4 hyperthreading is best on or off...


I look forward hopefully being of some use here and thanks again for the bang on target advice!

Link to comment
Share on other sites


  • Create New...