Jump to content

[help pls] OSX Retail 10.5.2 on Q6600


3 posts in this topic

Recommended Posts

Hi everyone! First of all, thanks for all the info in the group it's been great!


I'm still pretty new to this so sorry in advance if I'm missing anything or misinformed!


I've been reading all about the retail installs lately, and now that I have a macbook black running on 10.5.5, i thought I'd use my retail disk to replace hakintosh Kalyway 10.5.2 with the 10.5.2 OSX i actually bought! Easier said than done!


10.5.2 retail is two disks. My first attempt was using the Boot 132 method... I have two test systems, both are quadcore Q6600 one on asus P5KR and the other on a gigabyte P31 board. I can get the retail dvd to bootup but after choosing english I get something like "OSX cannot be installed on this system".


I created a separate Kalyway install on a 150GB USB drive, called it "rescuemac", and used it to format drive and attempt installation using .ISOs i created from the original disks. I got the same error when running OSInstall.mpkg ("OSX cannot be installed on this system").


So... I decided to install manually using Pacifist. I opened the OSInstall metapackage, selected everything, installed to the other virgin drive. That particular time I first set the drive up with EFI, then did that, then installed the 10.5.5 upgrade, then the post-patch. It would not boot up.


Randomly, I figured out that using the Boot 132 would load it up and let me configure the system, but as soon as it is configured, it kept flashing a blue screen and going back to black screen with a prompt. I thought it was video card related, but after fiddling around with both NVkush and NVinject i'm not so sure anymore.


I'm currently reinstalling again to test the system without the 10.5.5 combo upgrade.


Has anyone successfully gotten retail or other versions up to 10.5.5 on either of these motherboards w/ Q6600 cpu? Anyone with any advice or suggestions?




[edit] After initial problem booting, i tried adding chameleon, then tried copying over kexts from the v4.2 archive, then eventually just replaced the entire extensions folder with the 10.5.2 kalyway folder out of frustration and to see if it would kill the system. It did. I was gonna reformat anyway so why not.

Link to comment
Share on other sites

[update] Still no luck. Completed install again using Pacifist, upgraded to 10.5.5 using v1.1.4 release from mysticusC, i get a flashing blue screen but nothing loads up (I did manage to configure system, ie, registration windows, but then just get a flashing blue screen). I also tried directly upgrading from working Kalyway 10.5.2 - I get a "no" symbol like a no smoking sign.


If i figure this out, i'll post what ive been doing wrong :)

Link to comment
Share on other sites


  • Create New...