Jump to content

Inspiron 1720 10.5.1 xp dual boot Install

Arab the Stab

1 post in this topic

Recommended Posts

Well after a stressful week of crawling these forums its mostly working.




used Kalyway 10.5.1 (downloaded it ages ago and couldnt be bothered finding a newer version etc)




put three partitions one for osx, one for xp (dont like vista) one for shared data. (although since then have discovered macDrive which lets windows access mac drives which is cool and perhaps makes the data drive redundant, however its always good to have an os neutral place to store stuff). set up the partitions in disk utilities during the install.


installed os x first, then xp, xp sets its drive to boot so i used BootMagic from Hirens boot cd to set it back to the os x partition, then the darwin boot loader takes over and lets me boot both os's.

I would like to know how to set the default boot options in the darwin boot loader tho. id like it to boot the 2nd partition by default. but thats on the wish list for now.


ive been having a few problems with ACPI i ran the installer a heap of times over the week and sometimes id have to give it the -x or -f or both flags. if the machine was running on battery power i had more hassles trying to get the install to boot.


Install options,

didnt install the ACPI extra bits,

didnt install the networking options or the graphics or sound.


bootloader used the MBR


after the install, if the power was unplugged had to pass the -x or -f switch to boot, however if it was plugged in it booted fine.


bluetooth, touchpad, web cam all worked out of the box.


Inspiron 1720 has an Nvidia 8400M GS used NVInstallerV.41


used this kext to get the sound up and going, just replaced the one in System/Library/Extensions and fixed permissions on disk after AppleHDA.kext.zip . however i was messing around with AppleHDAPatcherv1.2 a lot before hand so maybe the fix came from here as well smart forum post to do with audio and stuff


then the wireless, some very loveable people have made a dell post installer

once i ran this my wireless worked like a charm.




on shutdown the os goes down the screen goes black but the machine doesn't actually turn off. I have to hold down the power button for a second or so to turn it off properly. help!


the wierd booting with the ACPI kernel panics when the power is not plugged in. once the system is booted i can unplug it, and i can ususally boot using the -f flag.


so i went and edited the com.apple.Boot.plist file and added the -f flag to the standard boot, this means that the kexts are being rebuilt every time i boot but it always boots.


any help anyone could give with the ACPI bits would be appreciated. im not really concerned with the power on shutdown its not a hassle, but the boot issues are irritating.

Link to comment
Share on other sites


  • Create New...