Jump to content

Successfully install Jas 10.5.4 on Intel DG31PR with Nvidia Video card


8 posts in this topic

Recommended Posts


There is a new patch and a new page to perfom the update to 10.5.5.



This update begins and ends with orage. It is about upgrading to 10.5.5 and Vanilla Kernel. This update is at the end.



The updates begin and end in blue. (There are two).


Well, I am one of the many that have tried to run Leopard on a ECS 945GCT-M/1333 motherboard, but I found the result a little unstable.


I began to try other motherboards, and I found the Intel DG31PR motherboard and gave it a try.


This is the hardware that I have used:


- Motherboard: Intel DG31PR

- Processor: Intel Dual Core 2.0 GHz / Intel Dual Core 2.2 GHz / Core 2 Duo 2.53 GHz

- RAM: 2 GB DDR2 667 MHz / 4 GB DDR2 667 MHz

- Hard disk: 500 GB SATA Samsung hard disk / 200 GB partition on a 500 GB SATA Samsung hard disk dual booting with Windows XP SP3

- DVD: WVW Writer LG

- USB Genius Keyboard and Mouse (PS/2 stuff doesn't work.

- Onboard video: It's too new, doesn't have QE, that's why I tried the nVidia video cards

- Video card: Nvidia 8600GT / Nvidia 8500GT / 9600GT (No QE)

- Monitor: CRT 1024 x 768 / LCD 19" Samsung 1440 x 900


BIOS Setup:

Here I didn't change too many options, it is set almost as it comes (default configuration).



SW Single Processor Mode: Disable

Date and time according to your place.




Boot Configuration: Deafault

Peripheral configuration: Deafault

Drive configuration: Deafault

Floppy configuration: Deafault

Event configuration: Deafault

Video configuration:


IGB DVMT Amount: 32

Primary video adpator: (Auto) or PCI-ex

Hardware monitoring: Deafault

Chipset configuration: Deafault

USB configuration: Deafault



Set Supervisor Password (I recomend to set the supervisor password to avoid that someone by mistake changes something in the BIOS).


Expansion card test: Disable

Chasis intrution: Disable

XD Technology: Enable



After Power Failure: Stay off

Wake on LAN from S5: Power on

ACPI Suspend : S3 status

EIST: Enable

Wake system from S5: Disable



Boot Menu type: Normal

Boot device priority: CD/DVD

Hard disk


The other options are not changed at all.



I have used to this installation the Jas 10.5.4 DVD, this is the setup of the DVD options:



The first thing you have to do is to either partition your entire hard disk, or erase the partition where you are going to install Leopard. Either one you have to choose MAC OS extended (journaled) partition type.


You have to use the DISK UTILITY to do this, it is in the UTILITY MENU.



After you have chosen where to install the OS, these are the options I have chosen:




Kernel Packages



Intel ICHx

Video cards

NVKush by Diabolik


UPDATE October 8th, 2008

Network cards



I am putting a new kext for this network card. It is 10/100/1000 and the drivers in the DVD are for 10/100. With the drivers on the DVD, th machine worked fine in a Windows XP network, but it didn't work so well in a Macintosh network. The machine could do internet but couldn't print o access files through the Mac network. I have just updated the drivers (kext) in the hackintosh in the Mac network, it took a few minutes but finally the machine saw all the Mac network. It can share files and use a network printer connected to a Mac.


End of update

Audio Driver


Device Identification

All Intel (There are 4 of them).


Superhai's SMBIOSResolver (The first one).




Once you click install don't stop the checking of th DVD integrity.




Well, I have disables the sleep option and the hard disk option. If they are one the machine stops and reboots.


I have tried to activated the PS/2 Keyboard and mouse ports, but after intalling the package the system didn't boot anymore, so I stayed with the USB keyboard and mouse.


There is a package to resolve the sleep problem but I have not tested it yet, as soon as I do, I will publish the results.




All of the software upgrades, except the 10.5.5 upgrade, have worked fine.


There is a way to install the 10.5.5 upgrade, as soon as I try it, I will publish the results.


UPDATE October 8th, 2008



First, download this file:




It has two files in it. One is the kext and the other has the instructions. Follow the instructions.


End of update





Adobe After Effects

Abode Photshop

Final Cut 2.0

Microsoft Office


I have tried this machine a Windows XP network and it worked fine. I copy files from the network without any problems.




Well to upgrade to 10.5.5 I followed this topic of the forum:




Name of the topic: Complete Updates for Newbies and All -- Currently 10.5.5 Combo (Only Intel CPUs), All future updates will be in the same topic


UPDATE Novembre 6th, 2008


Which sent me to this page:



This is the new page, go to UPDATE and you can download version 1.1.5

And also you have links to the disfferent OSX86 DVDs under DISTROS.

I haven't tested this version yet.


http://www.freewebtown.com/mysticus/index2222222.html (Version 1.1.3a of the patches).

You will need 3 files (they are actually two, since two comes in the same compressed file) to do a succesful upgrade 10.5.5, they are:


1. The original Combo Update of OSX 10.5.5 from Apple itself.


2. The Pre Update Patch.


3. The Post Update Patch.


The Pre Update and Post Update Patches you can download from the topic at post 1424 rolling the dice!!! (Click on the dice).


http://forum.insanelymac.com/index.php?sho...102&st=1420 Version 1.4.0 of the patches. (THESE ARE THE ONES THAT I USED)


Name of the topic: Complete Updates for Newbies and All -- Currently 10.5.5 Combo (Only Intel CPUs), All future updates will be in the same topic somewhere.


Follow these steps:


1. You run the Pre Update Patch, don't restart!


2. Apply the Apple's Combo Update to 10.5.5, and don't restart! DON'T RESTART!!!


3. Apply the Post Update Patch, and use CUSTOMIZE to select the items you need. When it finished, restart the machine doing click in the restart button on the screen.


These are the ones I used:




Kernel: 9.5.0 Vanilla Kernel

Chipset: Just restore my chipset

Video: Nvidia: NVKush

Audio: Just restore audio

Network: Jusst restore network


System functions:

SMBIOS Resolver (for Vanilla)

PS2 - Battery ....

USB 2.0 fixed latest


After I applied this Post Update Patch, I restarted the computer.


The computer boots twice, don't worry. The first boot is very fast, and the second is very slow. It takes from 6 to 10 minutes to finish the update. First you find a black screen and then a light blue screen, and finally the desktop appears.


Once the desktop appeared the machine ran normally. I rebooted the machine to check if everything was fine.


I took about 5 minutes to get to the desktop, but once in the desktop the speed was fine. This is why I decided to install the same kernel I install with the 10.5.4 DVD, the 9.4.0.




The onlu difference is the kernel the rest items are the same.


As before, it rebooted twice, adn took almost 10 minutes to finished the update. But when it finished and rebooted the machine, and the desktop appeared in less than 2 minutes!!!




Once the desktop appeard there is no speed difference between both kernels, the speed problem is at the beggining. The Vanilla Kernel takes about 5 minutes to boot, and the 9.4.0 takes less than 2 minutes. It is up to you which one to use. I stayed with the 9.4.0.




By the way this is the bios version I am using:



I have tested the USB ports with my Kingston pendrive, and it worked fine. I haven't tested any printers yet connected to the USB ports.


If it is working, don't update, specially the BIOS!!! The bios should only be updated if the CPU is not correctly recognized.



Link to comment
Share on other sites

I've the same motherboard, and I've install that version of leopard. but i've some problems with the usb devices, it can't detect pendrives and printers, the only thinks that works in the USB port is a Microsoft wireless Keyboard & mouse.


I hope you can help me.



I solve it. Don't UPDATE BIOS to 0057 [PRG3110H.86A](Last One) Becouse the USBs don't works, excepts for the keyboard.


Keep the 0047 Bios Version, i've to downgrade de bios to 0047 to have a fullworking leo.

Link to comment
Share on other sites

  • 2 weeks later...



I have checked the USB ports problems, and they are working fine with my pen drive. I applied the USB 2.0 fixed lastest when I upgraded to 10.5.5, maybe that is the solution since I have the bios PRG3110H.86A.0052. I haven't check them when I have the 10.5.4 OSX version, but a client who I sold one of this machine did, he copied the files to the machine through a pen drive since we are having trouble with the network at that time. (See first udpate).


Check the topic, I have put how to upgrade to 10.5.5.



Link to comment
Share on other sites

Hi ktheurer,


I am using the same setup as urs except Video card: Sapphire ATI x1600 Pro PCI card. I have chosen the same settings as urs with correct video drivers for ATi x1600 drivers.


But after installation and restart, and after the apple welcome movie nothing happens, i can still move my mouse but screen is grey and nothing happens.


Can you please help me to solve this problem?



Link to comment
Share on other sites

  • 2 weeks later...
Hi ktheurer,


Thanks for the reply m8.


My video card information:

Sapphire ATI Radeon X1600 PCI-E (512MB RAM)





Sorry to take so much time to answer, but I have to check if there is any new posts, since I don't receive any mail notification.


Back to business, check this out, it might help you.



Link to comment
Share on other sites


  • Create New...