Jump to content

Quad boot on single drive issues


5 posts in this topic

Recommended Posts

I'm trying to do a quad boot, with Dell Mediadirect (XP embedded), Vista, Ubuntu, and iDeneb 10.5.5. Because of hard drive limitations, OSX is on an extended partition. Currently it boots and works fine if I pop the DVD in, and let the timer run out. I've tried chainloading, it didn't work. I tried the /etc/chain0, but chain0 doesn't exist. Is there any way I can find out the kernel options, and put my grub entry in as "kernel /mach_kernel [options]", like a normal *nix kernel? Here's a look at some of what's on my OSX partition, thanks!

 

amp@Mobulus:/media/OSX86$ ls
AppleIntelGMA950GA.plugin			 cores			   Network
AppleIntelGMA950GLDriver.bundle	   dev				 private
AppleIntelGMA950.kext				 etc				 sbin
AppleIntelGMA950VADriver.bundle	   FireWire_Backup	 System
AppleIntelIntegratedFramebuffer.kext  home				tmp
AppleIntelPIIXATA.kext				Library			 Users
Applications						  mach_kernel		 usr
bin								   mach_kernel.ctfsys  var
boot								  net				 Volumes
amp@Mobulus:/media/OSX86$ ls etc/
6to4.conf	   irbrc						  podcastproducer
afpovertcp.cfg  kern_loader.conf			   postfix
aliases		 krb5.keytab					ppp
aliases.db	  localtime					  profile
amavisd.conf	locate.rc					  protocols
apache2		 mach_init.d					racoon
asl.conf		mach_init_per_login_session.d  rc.common
authorization   mach_init_per_user.d		   rc.netboot
autofs.conf	 mail.rc						resolv.conf
auto_home	   man.conf					   rmtab
auto_master	 manpaths					   rpc
bashrc		  manpaths.d					 rtadvd.conf
csh.cshrc	   master.passwd				  services
csh.login	   memberd.conf				   shells
csh.logout	  moduli						 smb.conf
cups			named.conf					 smb.conf.old
defaults		nanorc						 smb.conf.template
dnsextd.conf	networks					   snmp
efax.rc		 newsyslog.conf				 ssh_config
find.codes	  notify.conf					sshd_config
fstab.hd		openldap					   sudoers
ftpusers		pam.d						  syslog.conf
gettytab		passwd						 ttys
group		   paths						  xgrid
hostconfig	  paths.d						xtab
hosts		   periodic					   zprofile
hosts.equiv	 php.ini.default

Link to comment
Share on other sites

hey - i'm also having major grub/osx boot issues. from what i've heard, though, osx isn't supposed to be on an extended partition?

 

When booting from grub, have you made sure that OSX is Active? What is your grub boot entry, and what is the output of diskutil or fdisk -l? Have you tried netkas's pci_efi boot_v8 or chameleon bootloader?

Link to comment
Share on other sites

Yeah, at least the version I have does. 0x8* is the hard drive, but if you wait through the first timer to the second one and press a key, it should give you an option of what partition to boot to, and also allow you to pass kernel parameters

Link to comment
Share on other sites

 Share

×
×
  • Create New...