Jump to content

iDeneb v1.1 - Leopard 10.5.4 - ASUS P4C-800E Deluxe


1 post in this topic

Recommended Posts

Firstly: THANKS to iDeneb, OSx86Tools and InsanelyMac!


I am new to hackintosh, and had benefited greatly from postings by other members of InsanelyMac. I had previously tested iATKOS v4.0i - but ran into problems relating to NIC, which prevented my hackintosh from shutdown/restart - usually it just hang.


iDeneb v1.1 works best for me as it shutdown/restarted fine - so here is my little contribution to get iDeneb v1.1 working and running well on an ASUS P4C-800E Deluxe mobo with QE/QGL.


Good luck!






Section.1 = Hardware Info

Section.2 = BIOS Settings

Section.3 = Installation - Package selection

Section.4 = Modification

Section.5 = Getting QE/QGL to work

Section.6 = Niggles



Section.1 - Hardware Info, BIOS Settings


P4C-800E Deluxe, BIOS Revision 1019



Intel CPU 3.2GHZ, Family15, Model 3

Prescot, x86, MMX, SSE, SSE2, SSE3



2GB (4x512mb pc3200) 667MHz, Kingston



nVidia 7600GT 02e0 10de, AGP

Connected to VGA port - also tried connecting to DVI port, works.

Dual Monitor Work!



Analog Devices, SoundMax AD1985



Intel Pro/1000 CT






VIA OHCI Compliant IEEE 1394, VT6307


Intel 82801eb - UATA 24D1, 24DB






Section.2 - BIOS Settings


I'm no expert with BIOS settings. However, the followings works great for me. Standard configuration mostly.


I am using BIOS Revision 1019.




Legacy Diskette A = Disabled

IDE Config

__Onboard IDE Operate Mode = Enhanced, S-ATA





__AI Overclock Tuner = Standard

__Performance Mode = Standard


__CPU Max Value Limid = Disabled

__HT = Enabled


__Configure DRAM Timing by SPD = Enabled, Auto, Auto, Auto

__Graphic Adapter Priority = AGP/PCI

__Aperture Size = 128MB

__Spread Spectrum = Disabled

__ICH Delayed Transaction = Enabled

__MPS Revision = 1.4


__Onboard AC'97 Audio = Auto

__Onboard Promise = Disabled

__Onboard IEEE 1394 = Enabled

__Onboard Lan = Enabled

__Serial1+2 = Disabled

__Parallel = Disabled

__Game/MIDI Port = Disabled



Power-Suspend Mode = S3 only

Repost Video on S3 Resume = No

ACPI 2.0 Support = Yes

ACPI APIC Support = Enabled

BIOS --> AML ACPI Table = Enabled



Section.3 - Installation, Package Selection

1] Boot the iDeneb v1.1 DVD, my version was patched from v1.0 to v1.1, MD5 checksum



2] Use the Disk Utility (accessible from the Utility menu) to partition your HDD. I am using MBR boot method.


In my case, I went with:

Volume 1 = Leopard 100GB

Volume 2 = TimeMachine 200GB


I partitioned it this way just in case I need to reinstall or when something went wrong - all I need to do is to re-format Volume1. I keep data (like this writeup, kexts) and mac.app/dmg in Volume2 for testing purposes.


IMPORTANT: Name your volume WITHOUT spaces.



3] Exit Disk Utility and continue with installation, choosing the following packages and select "Leopard" as the target for installation.



Selected packages:

Additional Font


Audio - AC97

Chipset - ICHx Fixed

Kernel - 9.4.0 Modbin

Fix - AppleSMBIOS 667

Applications - ASU, Firefox 3.0.1, Kext Helper, menuMeters, Onyx, OSx86Tools, Pacifist, xBench


The above selected packages works for me - your mileage may vary.




Section.4 = Modification


If you are like me, you may not want iDeneb logo in About This Mac, but to replace it with a photo of your dog/cat/iguana/whathaveu. You can prepare a TIF image file and replace the standard logo by using OSx86Tools. Use OSx86Tools to replace the CPU string with the proper name: Intel Pentium 4 Prescot.



Section.5 = Getting QE/QGL to work

Getting QE/QGL to work is most problematic for me as I wrongly presumed I will need AGPgart.kext for my AGP card. If I install AGPgart, everything still works but I'll be confined to 1024x768.


I can get screen resolution changes thru Darwin settings but no QE/QGL. Any modification to nVidia***.kexts will result in the dreaded "Please reboot" during bootup (this happen when I tried iATKOS too).


Not having QE/QGL working on a hackintosh can really ruin the experience.


I am using a 7600GT-AGP, I only need NVDANV40Ha.kext and not the 10/20/30/50 kexts. I also found if you leave NVDANV10/20/30/50Ha.kexts in your /System/Library/Extensions folder, you'll get the "Please reboot" screen problem too.



a] Do not install AGPgart when you are trying to get nVidia AGP card to work.

b] Remove NVDANV10/20/30/50Ha.kexts, but keep NVDANV40Ha.kext



Although I'm writing for hardware detailed in Section.1 - I must caution you to know your video card, and which NVDANVxxHa.kext is required.


I'm using Natit_edited.kext, attached zip. Please unzip and use OSx86Tools to install the Natit.kext.


Do not reboot.

Run the task "Set Extensions permissions" in OSx86Tools.


Open terminal (can be found in Finder>Application>Utilities), be root

$sudo su


Remove unwanted kext

#cd /System/Library/Extensions

#rm -r NVDANV10Hal.kext

#rm -r NVDANV20Hal.kext

#rm -r NVDANV30Hal.kext

#rm -r NVDANV50Hal.kext



Modify (nano)

Matching device (IOPCIMatch) set to only contain 0x02e010de (nVidia 7600GT AGP)

Press ^W (Control W) to use the search function, search for IOPCIMatch

Press ^O (Control O) to write/save, ^X to exit


#nano GeForce.kext/Contents/Info.plist

#nano NVDANV40Hal.kext/Contents/Info.plist

#nano NVDAResman.kext/Contents/Info.plist




You can skip the following step. As this is just for on-screen cosmetic, as I like to see proper video card name.


Modify (nano)

Add in device 0x02E0 string = nVidia 7600 GT AGP8X under 10de device

Use Search as the Natit.kext is very long.


#nano Natits.kext/Contents/Info.plist












<string>GeForce 7600 GT AGP8X</string>





Remove Extensions cache

#rm -r /System/Library/Extensions.mkext


#shutdown -r now



Thant's it!


Hopefully your new hackintosh booted with QE/QGL fully working.



Section.6 - Niggles

Small niggle: LAN


My home network is DHCP-based. My onboard NIC will intermittently not acquire a dynamic IP from my router - a very small issue.


Work around:

1] Apple> System Preference> Network

2] Select Ethernet > Advanced button > Ethernet tab

3] Change Configure: Automatically to Manually

Speed: 100baseTX

Duplex: full duplex, flow-control

MTU: Standard 1500


4] Click OK > Apply


Remember to click Apply.



Link to comment
Share on other sites


  • Create New...