Jump to content

Problem with Intel HD Audio (Realtek ALC268 Codec)


2 posts in this topic

Recommended Posts

Hey guys,


I have troubles getting sound to work on a Vanilla/Retail DVD install, I tried various methods from this forum including Taruga patcher. Either I get no sound at all or I get sound without volume control.

On Kalyway 10.5.2 however sound works out of the box (with vanilla kernel) including volume control.


The sound output device shows up as "HD Audio Output" in Kalyway and my Vanilla system is unmodified except for the extra kexts (dsmos, AppleVIAATA AppleAHCIPort OpenHaltRestart, IntelCPUPMDisabler and SMBIOSENabler) and one boot.plist entry for my GFXcard.


My question now is: How do I figure out which files / settings on Kalyway are the ones that make it work.

(I tried copying random kexts from my Kalyway Extensions directory (Kalyway doesn't seem to have a Extra/Extensions dir) to my Retail Extra/Extensions directory without success, I also tried copying all kexts, but after that the system wouldn't boot at all (I made sure that both systems run 10.5.2 and repaired permissions) because of UUID mismatches in kexts or something like that.)


thx Chris

Link to comment
Share on other sites


  • Create New...