Jump to content

AC97 Sound Issue

4 posts in this topic

Recommended Posts

Hey guys,

I'm highly confident in this community and am sure I can find help here, so far I have everything working except onoard NIC and sound right now. I'm not worried about the NIC as I have a PCI card doing its job:)

so, I tried some things to et my dound working, I followed the steps outlines in the wiki for installing sound, and no sound, no option for sound in the system prefs.


I did everything listed in the wiki outlined here:



using 10.4.5


My vendor ID is 10DE

and my device ID is 0059


When I look in the Info.plist for the audio kext, my stuff is already listed, when I run kextload I get the following errors, modified or otherwise.

kernel extension /System/Library/Extensions/AppleAC97Audio.kext/ has problems:
Authentication failures
"File owner/permissions are incorrect" = (


so, what is one to do/cry

Link to comment
Share on other sites

Looks like it's a permission problem. Make sure the owner/group are root/wheel and permission is 755.


sudo chown -R root:wheel /System/Library/Extensions/AppleAC97Audio.kext

sudo chmod -R 755 /System/Library/Extensions/AppleAC97Audio.kext

Link to comment
Share on other sites


  • Create New...