Jump to content

Problema al apagar o reiniciar con kernel Vanilla


videl
 Share

17 posts in this topic

Recommended Posts

Tengo un problema similar pero solo al apagar (reinicio sin error): se apaga la pantalla pero siguen funcionando los dicos duros y el abanico, ya probe con el OpenHaltRestart.kext y no lo arregla, tambien probe con el PowerOffFix y solo se apagó algunas veces pero tambien dejo de funcionar, estoy utilizando la nueva versión de iDeneb con el Kernel 9.5 en una placa Gigabyte GA-EP45C-DS3Rcon procesador Q6600

 

Espero me puedan ayudar..

 

Saludos y Gracias de antemano.

Link to comment
Share on other sites

usa la extensión que he puesto un par de post arriba... debería de funcionar para ti tb...

Pues ya la probe sin exito, como dato adicional te comento que tengo el bios tal cual como tu amablemente me sugeriste en otro post, no se si estoy haciendo correctamente la instalación de kexts, lo que hago es lo siguiente: instalo el kext con kexthelper, y reinicio con -f necesito hacer algo más?

 

Gracias.

Link to comment
Share on other sites

Prueba usandolo conjuntamente con el ACPI vanilla, corrije permisos, y borra el archivo /system/library/extensions.mkext, reinicia con -f (backup del ACPI primero)

 

ACPI.zip

Primeramente muchas grácias por tu pronta respuesta.. ;)

A vers si entendi bien, primero hago un backup del ACPI original, luego instalo el kext ACPI que acabo de descargar, luego corrijo permisos, despues borro extensions.mkext y finalmente reinicio con -f

 

es asi como debo hacerlo?

 

GRACIAS!

Link to comment
Share on other sites

Has bajado 2 kext verdad? siempre que vas a instalar algo nuevo conviene hacer backup....

 

y si el metodo es ese

Baje el archivo, vienen 2 kexts, los instale, repare permisos (acabo de aprender a hacerlo), borre extensions.mkext, reinicie con -f y sigo sin poder apagar mi hackintosh :)

 

Repito, reinicia correctamenete, el problema es al apagar...

Aprecio mucho tu ayuda roisoft, tengo todo funcionando muy bien en mi recien armada hackintosh, el unico detalla es este, ya he probado varios metodos y ninguno me funciona.

 

Saludos.

Link to comment
Share on other sites

La extension está cargada pero por alguna razón no hace bien su trabajo...quizás tengas algún conflicto con el poweroff fix que tenías instalado...

Pues el poweroff fix ya lo habia desinstalado previamente (borrandolo de la carpeta de startupitems) no se si esto lo desinstala correctamente.

 

Sera bueno que instale nuevamente leopard? ya he movido muchas cosas tratando de solucionar este asunto..

 

Aal instalarlo me recomiendas que habilite el ichfix en las opciones? (es la unica opcion que habilito junto con el nvinject)

 

Sera bueno seleccionar nvkush en lugar de nvinject?

 

Es necesario seleccionar un tipo de emulador de bios?

 

Saludos y Gracias nuevamenete!

Link to comment
Share on other sites

No se hasta que punto has "movido/modificado" tu sistema, el ICHfix es necesario en algunos instaladores, y dependiendo de cada sistema ciertas extensiones retocadas para que todo funcione correctamente, en mi caso (y por tu hardware tb es posible) yo instalo a partir del retail usando chameleon+DFE eso me permite dejar mi carpeta de extensiones como viene de "fábrica" y lo ajustes los hago usando efi strings (audio, video,red)

Link to comment
Share on other sites

No se hasta que punto has "movido/modificado" tu sistema, el ICHfix es necesario en algunos instaladores, y dependiendo de cada sistema ciertas extensiones retocadas para que todo funcione correctamente, en mi caso (y por tu hardware tb es posible) yo instalo a partir del retail usando chameleon+DFE eso me permite dejar mi carpeta de extensiones como viene de "fábrica" y lo ajustes los hago usando efi strings (audio, video,red)

PROBLEMA SOLUCIONADO

Como ya habia movido muchos kexts y extensiones decidi volver a instalar iDeneb, la unica opcion que habilite durante la instalacion fue la de nVkush pra mi tarjeta de video, se instalo y reinicio y todo bien, instale el kext para el audio alc889, reinicie, instale el OpenHaltRestart kext y mi equipo esta funcionando a la perfeccion :)

 

Roisoft estoy sumamente agradecido, me has ayudado mucho, desde la seleccion de mi motherboard hasta como tenerlo funcionando perfectamente, eres una persona muy generosa al compartir tu conocimiento, tiempo y paciencia!!

 

GRACIAS!

Link to comment
Share on other sites

 Share

×
×
  • Create New...