Jump to content

File copy fails from USB devices


2 posts in this topic

Recommended Posts

Hi all,


I got a strange issue, maybe someone can help.

My OSX install is working great, but I have a few remaining problems :

* The major one are file copies that are failing after copying successfully several files. At first I thought it was due to NTFS3G since I was copying from an NTFS partition but I had the same issue from a FAT32 SD card after that. Any USB device ends unreadable after several (300 or more) file operation. Before the problem occurs, everything work. I have to disconnect and reconnect the drive in order to read it again.


On the other side, file operation work great for internal SATA drives (I've been copying and restoring disk images at file level without any problem, copying from network is also ok for 8000+ files).


* Since I updated to 10.5.5 some of my kext doesn't seem to load. I have a modified kext on my BOOT 132 usb drive to show internal drives as internal, non removable drives. It worked before but now it doesn't (I tried removing all caches and using -f at boot time). I read somewhere this could be due to the modified time of the kext, but I can't find the thread anymore.


My setup is in my signature, I put it here as a remainder :

OSX 10.5.5 retail w/ Boot 132

GA P35 DS4, E8500

nVidia 8500GT



Link to comment
Share on other sites

  • 2 months later...

Issues solved.

- That was due to my (any) USB2 hub. It was working perfectly with WinXP, but on OSX it makes all drives unstable. I had to remove all hubs.

- To force a modified kext to load, just increase its version number to something very high. (Contents/Info.plist)

Link to comment
Share on other sites


  • Create New...