Jump to content

External Hard Drive read error.


2 posts in this topic

Recommended Posts

Ok folks have an odd situation here, so here we go.


A buddy of mine has an external hard drive that is not being able to be read on his macbook running 10.5.5. Disk util says that the partition is named disks1k1 (something of the sort). On my osx86 tiger system it reads fine. The actual partition is named Untitled 1. When I look at on my osx86 it has all the files it should. It also works on his own pc running windows.


The macbook is running all the latest updates. When I go to click on the drive on the desktop, finder pops up and it says the correct capacity remaining at the bottom of the window. But the catch is that there are not files listed and the spinning (thingy) at the bottom right part of the window just continues to spin. The hard drive has some activity, but not much. I let it sit for a while and it never stopped doing that.


This drive has a fairly good amount of information on it that he'd like to use. He really needs it because he needs to start editing a movie with his camera.


A side note: the disk takes a fairly long time to unmount(15-20 secs)

Link to comment
Share on other sites

I actually have a similar problem.  I was trying to triple boot my MacBook (OS X 10.5.5, Vista 64 and OpenSuse 11.0). I tried resize my HD using terminal diskutil and I tried using Bootcamp Assitant, both failed due to some file wheren't able to get moved because they are being used.  So I needed to create an external boot and then DEFRAG my drive and then resize it.  Well I used Tech Tools Pro 4.6.1 to create EDRIVE (boot drive for repairs) on my WD Book Pro 1TB.  I selected one of my spare partitions and applied the settings.  Right after that my 2 partitions 1 for Backup and the Second one for personal data disappeared from my Desktop.  I ran Disk Utility and all I had was one partitions named Untitled 1 and my drive Disks1k1.  I tried running verify on the disk and it failed.  I ran repair disk and it failed.  The drive won't show up anymore in Tech Tools Pro for recovery, but it does show up on scans.  I tried restoring data by using Disk Warrior but it didn't even detect the drive.  After hours of reading forums I tried using TestDisk and this is the result that I got.


Disk /dev/disk2 - 1000 GB / 931 GiB - CHS 1953529856 1 1  

  Partition Start End Size in sectors  

P HFS 409640 1324540927 1324131288  

P HFS 1324803072 1534518271 209715200  

P HFS 1534780416 1953267671 418487256  




All my data is still on the drive, but I have no idea how to  fix the partition table again.  Please someone help.   I know I am almost there at fixing this, but I just can't figure out how to create new partition tables using the above values.  Please help, I have a lot of important data on that drive , that I can't loose.  


I also tried using no data loss format but that failed also.




Thank you.






Macbook 2.2 GHz Core 2 Duo


4GB Ram


160GB HD


1TB WD Book Pro II


OS X 10.5.5

Link to comment
Share on other sites


  • Create New...