Jump to content

Newbie - Problems Installing 10.5.2


jimlcpl
 Share

3 posts in this topic

Recommended Posts

Hi,

 

I am trying to install Kalyway 10.5.2 on an older PC that I have. I was able to complete the installation, but it wouldn't boot after that.

 

I think that at least part of the problem is that no NIC is being detected. So, I disabled the onboard NIC, and installed a 3com 3c905-TX, but even after re-installing Kalyway, still no NIC.

 

I found this thread:

 

http://forum.insanelymac.com/index.php?sho...01&hl=intel

 

and checked, and there is no Apple3Com3C90x.kext.

 

So, I downloaded the kext from 10.4.3, and extracted the kext, but how can I get that file onto the machine where I have Kalyway installed?

 

I've tried using a USB stick, but don't know how to access the USB stick. I also have a floppy drive on this machine, but can't figure out how to access the floppy.

 

If anyone can help with some information on the above, please post!

 

Thanks,

Jim

Link to comment
Share on other sites

Hi,

 

I'm hoping that I wasn't clear in my original post, and that's why no one has responded, so here's some additional information:

 

- The onboard NIC on my mobo was not recognized, so I added a 3com 3C905C-TX PCI card to my system.

- Even after that when I boot (sleepkernel -legacy -s) to single-user mode, I can see that it didn't recognize the 3COM NIC

- So, I was researching, and found the link about getting the Apple3Com3C90x.kext file from 10.5.43, which I've downloaded on a different machine.

- Now I have the kext on a different machine, but I can't figure out how to get the kext into the OSX file system, because, as explained, I don't have any network connectivity (because no NIC is recognized) when I boot into OSX

 

So, this is a bit of a conundrum: OSX doesn't recognize my NIC. I have (I think) a kext that might allow OSX to recognize the NIC, but it's on a different machine, but I can't figure how to get the kext from the other machine to my OSX filesystem.

 

I have both a floppy drive on the OSX machine, and I have some USB flash sticks, but, when I boot into OSX single-user, I can't see how to get access to either the floppy or to the USB flash stick. I've checked /dev, and there is a /dev/fd, but /dev/fd0, or something similar doesn't exist. There is no /media either, so I can't get to the USB stick.

 

The thread I linked in my original post implies that there is a way to get the kext onto the filesystem, but I can't figure out how to do that.

 

Can anyone help with this??

 

Thanks,

Jim

Link to comment
Share on other sites

Hi,

 

FYI, I just got this working!!

 

The only problem is that I don't exactly know what I did to get a successful installation :2cents:...

 

For the record, here's what happened, highlighting points that I think I did differently from earlier failed attampts:

 

0) I had figured out a workaround for my earlier problem, where I couldn't figure out how to get the 3COM kext onto my installed OSX filesystem. What I did was add a hard drive, which was then visible, and I copied the kext to that 2nd hard drive. Then, when I did "mount -t msdos /dev/disk0s1 /mnt", I could see the 2nd hard drive.

 

1) I had been trying some things to get the 3COM 3C905C-TC NIC recognized, e.g., chmod/chown the kext, and kextcache -k, but ended up trashing the installation so it would no longer boot, so I decided to do another installation.

 

2) So, I booted to the DVD installer, and erashed the partition (Extended, journaling)

 

3) After that, I was thinking about the 3COM problem, and the thing was, the 3COM kext was not showing up in the installer "Customize" thing. This was rather strange, because when I used the Network Utility in the installer, that DID see the 3COM NIC, and I could ping, etc. successfully. I was guessing that the installer runs on some kind of temporary ramdisk or something, so I thought that I'd try to copy the 3COM kext to the /System/Library/Extensions dir while I was in the installer, hoping that then the 3COM kext would appear under "Customize".

 

4) So, I started a terminal in the installer, cd'ed to /System/Library/Extensions, and copied the 3COM kext from the 2nd hard drive (something like "cp -r /Volumes/2nd/IONetworking..../Apple3Com....kext ./"), but I got a bunch of errors, probably because the ramdisk or whatever the installer sets up was read-only.

 

5) I figured that failed, but I went ahead and did the install anyway, using "Customize". The 3COM still didn't appear in "Customize", but I went through that and started the install, then I walked away for awhile.

 

6) When I came back to the machine, I was AMAZED to see the Apple registration window!!

 

7) I went and did Alt-Q to skip the registration, and then I got the desktop!!

 

 

Like I said above, I really don't know what of the things I did this time made it work, but it is working now. I'm thinking that somehow that "cp -r" that failed did it, or maybe it was just letting it boot through automatically (I was trying "sleepkernel -legacy" earlier.

 

If I have some time later, I may try to blow the whole installation away and try to re-create what I did, but right now, I'm just glad that it's working so that I can move on with other things :(!!

 

Hopefully these notes might help someone else here.

 

Here's my hardware config:

 

MB: MSI K8NGM2-FID

CPU: AMD Athlon 64 3000+

HD: Two IDE Drives (Seagate and Samsung)

Video: ASUS EAX1600PRO SILENT/TD/256M Radeon X1600PRO 256MB (PCI Express)

NIC: 3COM 3C905C-TC (PCI)

 

Later,

Jim

Link to comment
Share on other sites

 Share

×
×
  • Create New...