Jump to content

[P35-DS3 + HD2600 XT] Weird problems on 10.5.4 retail. Please help.


1 post in this topic

Recommended Posts

Greetings to the community!


This is my last chance to get help from gurus as all the searching and my own experimenting gives nothing. If anyone has a clue of a solution - this will be appreciated.


So let me stick to the point.

I have a very compatible motherboard Gigabyte P35-DS3(L) and Radeon HD 2600 XT (PCIe, 256 Mb) GPU.


I've been making my own install DVDs of Leopard since 10.5.0 from retail DMGs using PC_EFI and as little patched kexts as possible to keep things totally vanilla.

These changes are:


1. dsmos.kext

2. AppleIntelCPUPowerManagement.kext (removed)

3. ApplePS2Controller.kext (PS2 Controller)

4. Natit.kext (Graphics)

5. IONetworkingFamily.kext (Time Machine fix)

6. AppleHDA.kext and ALCInject.kext (ALC888 sound)

7. AppleACPIPlatform.kext (restart fix)

8. AHCIPort.kext (ICH9R)


When a compiled my own install DVD from 10.5.0 (Retail) - everything worked like a charm. Not an issue for all time.


Then i got a MacBook Pro Restore DVD with 10.5.2 and remade it to to act like a retail one with the same set of patched kexts mentioned above. Again it was a success. Everything worked and was booting very fast.

Today a have the same install updated to recent 10.5.5 - again not an issue!


And now we are getting close to my weird problems.

I few days ago i downloaded an original 10.5.4 Retail image to remake in with my method and switch to Chameleon as it seems that it has a better potential. So i restored it to a separate HDD to test before the actual compiling, replaced the same set of kexts and installed Chameleon.


When i boot i get one very strange issue (or probably two - you will see later):

It boots to the screen with language selection all stripped and dotted (totally messed). I supposed it was a Natit problem, as it worked in an 10.5.0 updated to 10.5.4 install, but doesn't work in retail 10.5.4


I removed Natit to see how it would run without it and now i see it stucks at mDNSResponder failing to set machine name or something. What the hell?


Then a replaced my old patched kexts with ones from ~pcwiz Control Center (http://forum.insanelymac.com/index.php?showtopic=121805) just to test.

Nothing changed! With natit it boots to messed screen, without in stucks at mDNSResponder.


When i remove the entire 10.5.4 Extensions folder and replace it with compiled Extensions.mkext from my previous 10.5.2 DVD - it works fine again.


My head spins around and i wasted 3 days to manage this bloody thing.


I am very sorry for being such wordy but this is the only way I can explain things happened.

Of course i cleaned Caches directory an booted with -f switch. No luck.


Please, if anyone knows why:

1. Same set of patched kexts works in 10.5.2 updated to 10.5.4 and doesn't it 10.5.4 from start?

2. What prevents my install to boot? Natit, mDNSResponder or something else?


Thanks in advance. I think that probably someone already came across this too.


Cheers, Dimarzio.

Link to comment
Share on other sites


  • Create New...