Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
outZider

Gateway C-5815 Convertible Tablet (and similar models)

3 posts in this topic

Recommended Posts

Hey, I'm oZ, and I seem to be collecting laptops. I've been trying to find the perfect laptop for my needs, and with that, the perfect laptop for OS X. My last Apple machine was a Core Duo Black MacBook, which was a complete lemon, and I ended up selling it off. Since then I've had a ThinkPad X61 Tablet, which was great, but we needed money, so I sold it and got a 14" ThinkPad T61, which was also a fantastic machine, but larger than I wanted. So, here we are.

 

This last weekend, I picked up a Gateway C-5815 Convertible Laptop, which is the same machine as the Gateway C-120, as well as very similar to the E-155 and S-7125, and MPC S-7235C. I don't get why Gateway does this, it makes it really hard to find support for the model. I'll try to keep a list of similar models so searching can find what you're looking for.

 

I'll update this as soon as I find new things to talk about, and please, if you find out anything new, post it here so I can push it up to the top.

 

Updates

2008-09-19: Add additional clarification

 

Initial Installation

I used the iATKOS v4i distribution. Others will likely work, but be warned that the JaS 10.5.4 distribution has a bum GMA950 driver, so you'll boot to a blue screen.

Boot into an Ubuntu Live CD, or your linux distro of choice.

In System > Administration > Partition Editor, resize your Vista partition to a size that is comfortable for you. This will take a few minutes. Do not create a new partition in the free space.

In Applications > Accessories > Terminal, enter "sudo cfdisk". [C]reate a partition, it will fill the disk by default. Change the [T]ype to 'AF'. [W]rite the changes, and exit.

Boot into your distribution.

At the opening screen, after clicking Continue, go to the Utilities menu and select Disk Utility.

Select your newly created partition (If you can't tell by the names, select them and look at the bottom of the window, and see if the size matches the partition you created. If you set the Type correctly, it'll also say Mac OS X Extended at the bottom.)

Erase the partition as Mac OS X Extended. Be sure you have a PARTITION selected, and not the whole DRIVE, or you will nuke your Vista installation! (Unless, of course, that's what you meant to do)

Once complete, quit Disk Utility.

Customize your installation, select vanilla AppleACPIPlatform and kernel. Install the third party SATA kexts to support ICH7, and install the Intel PRO/100VE driver for ethernet support.

Install.

Reboot.

Huzzah. Follow the below to enable other features of your laptop.

 

Power Management

I've found that the best way to do the battery meter now is Chun Nan's ACPIBatteryManager. You keep your stock PowerManagement.bundle and AppleACPIPlatform, and add this kext to your Extensions. You can then get a battery meter and proper battery statistics. He did a great job here.

http://forum.insanelymac.com/index.php?showtopic=114105

 

Graphics

GMA950 worked out of the box on every installation except for JaS 10.5.4. Rotation doesn't seem to work. External VGA seems to work great with mirror or as a second display. I had success with backlight adjustment with the kext found in this thread, but it caused some serious mouse artifacts with developer custom controls, such as Firefox or Microsoft Office:

http://forum.insanelymac.com/index.php?s=&...st&p=612710

 

Sound

Sound is based on the SigmaTel 9205. The below link worked well for me, except I only have audio out of the speakers -- no headphones or microphone yet. I'm going to be playing with that over time.

http://forum.insanelymac.com/index.php?s=&...st&p=680141

 

Ethernet

The ethernet controller is an Intel 82573L Gigabit Controller (8086:109a). There isn't /native/ support for it, but the Intel PRO 100 VE driver included in the iATKOS distro works just fine.

 

Wireless

The wireless card is an Intel 3945ABG wireless card (8086:4222), corresponding to the Centrino platform. You're SOL, and have to get a different wireless card, or a USB wireless dongle. Luckily, Gateway didn't lock down the BIOS, so you can get yourself a cheap Dell DW1390, and it'll work just fine. I grabbed a dirt cheap Broadcom 4311-based adapter off of eBay that happened to be from a Toshiba, plugged it in, connected the wires, and OS X detected it at next boot without an issue. Pimp.

 

Tablet

Gateway actually led the pack with this one, with a USB-connected dual digitizer from Wacom, supporting pen and touch input. The problem with this, of course, is that TabletMagic isn't going to work because the digitizer is USB, and the Wacom drivers aren't going to work because of either an invalid match or being confused by the dual digitizers. So, your tablet shows up as a standard HID device, the Wacom example software registers proper pressure sensitivity and buttons, and you can't friggin calibrate the device because Apple doesn't have a native friggin calibration tool. This is probably my next priority, whether by altering the TabletMagic driver, reverse engineering the Wacom driver somehow, or just bugging Wacom. Altering TabletMagic seems to be the best option right now, since Wacom isn't answering.

 

Fingerprint Reader

Standard stuff, and UPEK has software for us if you want to authenticate your hackbook with your fingerprint. This allows you to use your finger print on any system-level password service, including login, keychain, and privilege escalation for installations.

http://www.upek.com/mac/download

 

PC Card/Cardbus Slot

You seem to have a choice with this. Chun-Nan's PCCard patch works with this machine, and successfully detects our Cardbus slot. Once you've activated this, though, you lose sleep capability. I guess it depends on your priorities.

http://forum.insanelymac.com/index.php?showtopic=81036

 

SD/MMC Card Reader

Nothing yet. :(

 

Working out of the box

CD/DVD Reading and Writing

FireWire

USB 2.0

Sleep/Wake

 

Untested

Dock: I don't have a dock to see if the dock connector works. I'm assuming that it'll work just fine if you boot with it, and won't do a thing if you connect it mid-power.

 

Exact or Similar Models

Gateway C-120 / C120 / C-120x / C120x

Gateway C-5817 / C-5817c / C5817c

Gateway S-7125 / S7125

Gateway E-155 / E155 / E-155c / E155c

MPC S-7235C / S7235C

Share this post


Link to post
Share on other sites

@!#$. Everything annoys me right now. So, OS X sees the tablet, but it's not properly calibrated to the screen -- the arrow doesn't match where the pen is dropped, it's almost like it's tuned for another resolution. Apple doesn't provide a calibration tool, but if you get their HID code examples, you see that the pen is properly communicating pressure and full resolution to Apple's HID manager. Wacom's development examples also show the same thing. The Wacom drivers, however, won't lock on to the device, so you can't use Wacom's calibrator.

 

FFS. C'mon.

Share this post


Link to post
Share on other sites

How did you go with this? I noticed the same issues using the HID tools from apple - everything is working as it should, including touch, on my thinkpad x220t. Im wondering if we can spoof the hardware ID somehow so that the wacom driver picks up the tablet?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×