Jump to content

Kalyway 10.5.2 installs but no video.


4 posts in this topic

Recommended Posts

Hi all,


This is my first foray into the hackintosh world, but after getting a new 24" iMac at work the other day, I knew I had to have Leopard on my laptop.


Anyway, I tried installing iatkos v4i first, but that wouldn't even make it through the install. Then I installed kalyway 10.5.2. It made it thru install, rebooted, showed the grey apple logo with the loading spinner, and then my screen flickered with a weird pattern and went black. However, the install worked because I heard the sound from the welcome video, but again, nothing on my display.


I have a Thinkpad z61m with a 1.83Ghz Core Duo, 3GB RAM, ATI Mobility Radeon x1400, and the intel i945GM chipset. I installed OSX on a 60GB USB HD with the vanilla kernel, and I selected ATIx1000 series and natit kexts like the installer said. Everything seems to work but the video. No problems with booting, sound works, and even my thinkpad ultranav mouse. What do I need to change to get my video working, and can I do it in darwin or the installer on the DVD?


Thanks for your help, and I appologize if this has been addressed already or if I'm posting in the wrong place. I've done a fair bit of research to get to this point and I just need a suggestion or two to get this up and running. I'm so close I can taste it!


*Edit* I ran the boot with -v and nothing obvious showed up, but everything scrolled by pretty fast.

"If you would like to use voiceover to setup your Mac, press the esc key." Arrrgh! No! I want to use my eyes and my mouse and my keyboard! lol

Link to comment
Share on other sites

  • 2 weeks later...

I had a similar issue installing kalyway 10.5.2 on my Thinkpad T60. Everything installed fine but when it tried to bring up the desktop the screen had a stripped pattern and then faded to black. I have seen that before with Windows using the wrong video mode.


So I found a way to force the video to my laptop's native resolution of 1040x1050. And that fixed the problem.



Boot to command prompt by hitting F8 at startup.

enter -s (to boot single usermode)

mount -uw / (this mounts the disk)

change to the /Library/Preferences/SystemConfiguration/ directory

edit com.apple.Boot.plist

Add this line after the kernel flags key line

<string>"Graphics Mode"="1400x1050x32"</string> (Use your native resolution)

save and exit your vi session



This worked on my T60 and my Dell Precision 390.


I tried Leo4all image and it didn't have an issue with the video on either machine.

Link to comment
Share on other sites


  • Create New...