Jump to content

[Partial Success] with Linux KVM and Leo4Allv3


1 post in this topic

Recommended Posts

Hi All,

Just a note that I managed to get the Leo4Allv3 DVD iso booting on Linux' wonderful KVM, for more detail on KVM see:




I'm using the most recent version (kvm-75) together with a processor that supports Intel's VT technology. In this case an Intel Q9300. You must have an Intel-VT or AMD-V capable processor to use KVM.


First I create a 10GB disk image:


qemu-img create -f qcow2 /mnt/store/kvm-master.qcow2 10G


Then I start a KVM virtual machine process with my Leo4Allv3 ISO image, with 512m of RAM and my new blank 10Gb hard disk. I also request a Virtual Network Console connection (my physical box is headless) and specify that I want to boot from the cdrom/dvd image:


kvm  -drive file=/mnt/store/Leo4Allv3.iso,media=cdrom -drive  file=/mnt/store/kvm-master.qcow2,media=disk -m 512 -vnc :1 -monitor  stdio -boot d


I connect remotely to the console with "vncviewer targethost:1" and start a normal install... using the Apple Disk Utility to partition my 10Gb disk as I see fit (8Gb extended journaled, 2Gb FAT). I then proceed with the installation (takes about 12 mins).


When I rebooted after the install I get the infamous "still waiting on root disk..." but it turns out that this is due to the appropriate kvm ATA drivers existing on the ISO but not having been copied to my target hard disk!


So I followed these steps found at:




To copy the ATA drivers on the ISO over to the virtual hard disk.


Rebooted and all was dandy.


For subsequent start ups I specify that kvm should start up using the disk image rather than the ISO image:


kvm  -drive file=/mnt/store/Leo4Allv3.iso,media=cdrom -drive  file=/mnt/store/kvm-master.qcow2,media=disk -m 512 -vnc :1 -monitor  stdio -boot c


Now I just need to figure out networking and sound. KVM emulates an RTL8139 network card and a ENSONIQ AudioPCI ES1370 sound card.


I've tried installing various RTL8139 kext's but with no joy... initially I did have it burst into life about 20 mins after boot but it only worked for about 2 minutes before dying (all packets ceased). No joy since.


The sound card appears to be recognised and a driver loaded but there are no input or output devices are listed and the Sound control panel dialog items are disabled.


Since networking isn't up it's quite hard to get info in and out of the box... but here's what System Profiler tells me about the network and audio hardware it finds:



Type: Ethernet Controller

Driver Installed: Yes

Bus: PCI

Slot: PCI Slot 3

Vendor ID: 0x10ec

Device ID: 0x8139

Revision ID: 0x0020


Type: Audio

Driver Installed: Yes

Bus: PCI

Slot: PCI Slot 4

Vendor ID: 0x1274

Device ID: 0x5000

Subsystem Vendor ID: 0x4942

Subsytem ID: 0x4c4c

Revision ID: 0x0000


I noticed that the RTL8139 kext referred to revision ID 0x0010 rather than 0x0020 and wondered wether this might be the issue. I also see mention of a failed "family" match in ioreg e.g.


+-o com_appe_driver_RTL8139  <class com_apple_driver_RTL8139, !registered, !matched, active$


Any thoughts on either issue hugely appreciated! The network being the more pressing issue.


P.S. I'm a novice when it comes to OS X, but I do know a fair bit about GNU/Linux.





Link to comment
Share on other sites


  • Create New...